Comments in blockquotes not darkened in editing mode

Steps to reproduce

  1. Make a blockquote using "> "
  2. Type anything enclosed with two percent signs (%%)

Issue applies to both Live and Source Editors.

Expected result

Actual result

Environment

  • Operating system: Windows 10
  • Debug info: (Using a Sandbox Vault)
	Obsidian version: v1.1.9
	Installer version: v1.0.3
	Operating system: Windows 10 Enterprise LTSC 2021 10.0.19044
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on

RECOMMENDATIONS:
	none

Additional information

I just updated to 1.1.9 last night, this wasn’t a bug in 1.0.3 :frowning:

Going deeper into it, the issue actually goes beyond just comments. Other text formatting features are affected as well, not being rendered in either editor.

I’ve found Headings, Lists, Code Blocks, Tasks, Tables, and Dividers to be problematic. Didn’t check Math, Callouts, and Diagrams as I’m unfamiliar with those. Best reproduced and tested by blockquoting every text formatting example in a Sandbox Vault.