Command + x on Mac does not "cut"

Once you’ve done the above, delete everything above this line.

Steps to reproduce

select text highlight
press command + X to cut

Expected result

cut the text to paste elsewhere

Actual result

nothing happens

Environment

  • Operating system:
  • Debug info:

SYSTEM INFO:
Obsidian version: v1.1.9
Installer version: v1.1.9
Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:15:52 PDT 2022; root:xnu-8792.41.9~2/RELEASE_ARM64_T8112 22.1.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 1
Restricted mode: off
Plugins installed: 13
Plugins enabled: 13
1: QuickShare v1.3.1
2: Advanced URI v1.31.2
3: Boost Link Suggestions v1.0.1
4: Breadcrumbs v3.6.4
5: Dataview v0.5.53
6: Excalidraw v1.8.9
7: Fleeting Notes Sync v0.5.1
8: Kanban v1.5.1
9: Metadata Extractor v1.1.0
10: Mind Map v1.1.0
11: Omnisearch v1.9.1
12: Simple Embeds v1.14.1
13: Templater v1.16.0

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

Test this in the Sandbox vault please.

Check your hotkeys, that you didn’t map Cmd-X to something else.

I can’t reproduce this. (For now I’ll move this to Help, until more info is given. Thanks.)

1 Like

I’m a little afraid to ask this but you’re in an editing mode, not reading mode? You’re able to type stuff, when you try to cut the text?

(I’m almost ashamed to admit, but I’ve tried similar operations whilst in reading view… )

2 Likes