Code block with intend messed up in live preview

Steps to reproduce

markdown code is shown above, I can’t write here, because it will mess up the markdown here

the bug has nothing to do with third party plugins.

Expected result

image

Actual result

Environment

  • Operating system: windows 11
  • Debug info: SYSTEM INFO:
    Obsidian version: v1.0.3
    Installer version: v0.15.9
    Operating system: Windows 10 Pro 10.0.22623
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Minimal
    Snippets enabled: 1
    Restricted mode: off
    Plugins installed: 20
    Plugins enabled: 18
    1: Advanced Tables v0.17.3
    2: Quiet Outline v0.3.6
    3: Minimal Theme Settings v6.1.0
    4: Regex Find/Replace v1.2.0
    5: Better Word Count v0.8.1
    6: Kanban v1.5.1
    7: Emoji Shortcodes v2.1.3
    8: Emoji Toolbar v0.3.2
    9: Calendar v1.5.10
    10: Outliner v4.1.1
    11: Dataview v0.5.47
    12: Homepage v2.4.1
    13: Paste URL into selection v1.7.0
    14: Quick Latex for Obsidian v2.5.1
    15: Pandoc Plugin v0.4.1
    16: Remotely Save v0.3.25
    17: Templater v1.16.0
    18: Style Settings v0.4.12

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

does it happen in sandbox?

you have misaligned backquotes. We also don’t support well codeblocks in lists in LP. there is an open feature request.