Cmd+Z is not working when I accidentally deleted text in a Note on Canvas

While I was working on a Canvas, I selected some content on an attached Note and accidentally hit backspace… I tried cmd+z/undo, but it’s not restoring the deleted info! Am I missing something? Is this a weird thing that happens when you edit Notes while on a Canvas? I’m relatively new to Obsidian, and I don’t have any snapshots to restore from… is my info gone?
Version 1.4.16 on macOS Sonoma 14.0

When you say you “selected some content on an attached Note”, can you be a bit more specific on the exact steps and where?

I just tried deleting random text from text cards and note/file cards using Backspace, then using ctrl + z (on Windows at the moment) restored the deleted text as expected.

If the missing text is from a note/file card (sounds like it is), you can try Settings > File Recovery > Snapshots -> View and start typing the name of the note. You may be able to find a previous version of the note and restore the missing parts.

1 Like

Thanks, when I looked at snapshots there was nothing there (I expected to see a list), but typing the name of the note into the search bar did the job… Thanks!!!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.