Cmd+Ctrl+↓ Plays the "beep" error sound in Obsidian text editor, even though I have it mapped to hotkey "Move line down"

Steps to reproduce

  1. Put focus in text editor (source/live-preview/legacy, any)
  2. Press cmd+ctrl+↓

Expected result

  1. No sound should be played
  2. If you have this hotkey mapped to “Move line down”, then any text on the current line will move down

Actual result

  1. Beep error sound, with no discernable reason
  2. If there is text on the line, it moves down as expected, no issue in that regard

Environment

  • Operating system: mac os 10.14.6 Mojave
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.14.6
    Installer version: v0.14.6
    Operating system: Darwin Kernel Version 18.7.0: Tue Jun 22 19:37:08 PDT 2021; root:xnu-4903.278.70~1/RELEASE_X86_64 18.7.0
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Minimal
    Snippets enabled: 13
    Safe mode: off
    Plugins installed: 24
    Plugins enabled: 14
    1: Templater
    2: Periodic Notes
    3: Pane Relief
    4: Advanced URI
    5: Style Settings
    6: Emoji Shortcodes
    7: Minimal Theme Settings
    8: Hider
    9: Jupyter plugin
    10: Mochi Cards Exporter
    11: Better Word Count
    12: Excalidraw
    13: Dataview
    14: Electron Window Tweaker

Additional information

  • I’ve tried quitting all applications and menubar apps, to be sure that none of them are producing the sound
  • I’ve gone through every shortcut in System Prefs → shortcuts to be sure nothing else is mapped to cmd+ctrl+↓ that would produce this sound
  • I’ve tried disabling all community and core plugins and being in safe mode
  • I’ve tried switching to default theme, and disabling all snippets
  • I also tried this in Obsidian sandbox vault

In all circumstances Obsidian seems to make an error sound with this shortcut, even though it actually executes the shortcut properly.

Have you tried closing Obsidian itself and pressing the key combination?

I agree this can a third party or OS issue.

Ah, I should have specified, yes I have tried that - I have two other text editors that use this same keyboard shortcut (Nova and Sublime Text), and when I perform it in those apps there is no sound. So currently it appears to me to be an Obsidian issue.

On Obsidian discord there were two other mac Obsidian users who confirmed that this key combination triggers the sound for them, but as far as I know neither of them had setup the keycombination to perform the “move line down” action.

According to this thread it might be an issue with electron: ctrl-cmd-down combo for switching lines produces a sound · Issue #1669 · atom/atom · GitHub

The workaround someone suggests in that thread of adding { "^@\UF701" = "noop:"; "^@\UF702" = "noop:"; "^@\UF703" = "noop:"; } to DefaultKeyBindings.dict and restarting Obsidian worked for me, incase anyone else comes across this issue.

Thanks for digging this up. It seems that this goes all the way up to chrome and maybe osx.
And Nobody wants to fix it.

https://github.com/electron/electron/issues/2617

https://bugs.chromium.org/p/chromium/issues/detail?id=916460