Clicking twice on the "back" button maximises the window

Steps to reproduce

Click twice quickly on the left arrow in the titlebar of the window – the one that looks like this:

Screen Shot 2021-08-19 at 7.07.32 PM

Expected result

Clicking two (or more) times in quick succession on the left arrow should simply page back through the history of pages you’ve visited, and not maximise the window – the window should only maximise if you double click on the title bar outside of the arrows.

Actual result

The window is maximised. If the window is already maximised, then the window size is restored.

Environment

Mac OS 10.15.7
Obsidian version 0.12.13

Additional information

The same thing happens when clicking twice quickly on the right arrow as well.

3 Likes

kuva
Just to help narrow down the bug, I tried the same thing on Windows 10. On Windows 10, double clicking both backward and forward arrows work correctly and the window does not maximize. So this seems to be something Mac specific.

Also on Linux (Xubuntu 20.04) it works correctly.

2 Likes

On macOS, double clicking on the bar at the top of a window maximises the window as a standard OS behaviour.

I came across this electron thread that may be relevant.

Can’ŧ repro on Linux Mint 20.2/Cinnamon and Ubuntu Studio 14.04/XFCE.

Double-clicking the title bar also maximizes/unmaximizes_, as expected. The “Go back” and “Go forward” buttons work as expected, even when accidentally double-clicked.

1 Like

Double clicking the title bar to maximize the window is a standard OS behaviour also in Windows and Xubuntu. What I meant with “So this seems to be something Mac specific.” was that the bug seems to be Mac specific, meaning that the bug only occurs on Mac.

can you post a screen recording of this happening in the help vault?

Double-clicking too quickly causes the window to zoom (or minimise, depending on the setting in Apple → System Preferences → Dock & Menu Bar → Double-click a window’s title bar to zoom / minimise).

Although that speed can be adjusted in Apple → System Preferences → Accessibility → Pointer Control → Double-click speed.

Not an issue for me. Just providing the screen recording requested.

ObiMac

Angel

3 Likes

Thanks, @Angel – you bet me to it.

The same happens to me on macOS Monterey v12.2. But given my macOS settings it actually minimizes when I accidentally double-click.