CJK VIM: some characters disappearing at the right edge of editor

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

This problem is occurring after 0.14.6 (how can I install previous version?)

I made screen recording.


Actual result


  • Operating system:
  • Debug info:

Sandbox mode
Vim key binding on.
Safe mode is on (no community plugins)

Obsidian version: v0.14.6
Installer version: v0.14.6
Operating system: Windows 10 Enterprise 10.0.19043
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Safe mode: on


1 Like

Does it happen in source mode?
Does it happen here https://codemirror.net/demo/vim.html?
Which IME are you using? Does it happen with windows built-in IME?

I am using windows 10 built-in IME.

It’s not reproducable on CodeMirror: Vim bindings demo , because the page does not wrap line(image below).

does it happen in this version of obsidian https://github.com/obsidianmd/obsidian-releases/releases/tag/v0.14.2?

0.14.2 is OK.

wow, I did not know where I can download previous version.
I did rename C:\Users\wafe\AppData\Roaming\obsidian folder and install 0.14.2 .
and off the option for automatic update.

what happens if you enable automatic updates?
Don’t download and reinstall from the website, just use the internal update system.

If it does happen, do you get errors in console (ctrl-shift-i)?

my obsidian is updated to 0.14.6 automatically from 0.14.2.

character disappearing problem did come back and there is no output on develop console.

Does it happen here https://codemirror-vim--util.repl.co/ (enable wrap)?

Does it happen in source mode?

I also encountered similar behavior.

[Reproduction procedure]

  1. Open Sandbox vault
  2. Enable Vim key bindings
  3. Replace the first line with ああああああああああああああああああああああああああああああああああああああああああ
  4. Input ああ by pressing aa[Enter] with IME on
  5. If not reproduced, Delete ああ by pressing [BS][BS] and repeat 4


Obsidian version: v0.14.7
OS: Windows10
IME: Microsoft IME (use Japanese)

Does it happen in source mode?


do you get errors in console (ctrl-shift-i)?


Does it happen here https://codemirror-vim–util.repl.co/ (enable wrap)?


FYI: Not fixed v0.14.15

@wafe, thanks a lot for posting this. I spent hours digging others - custom themes, plug-ins etc.

I rolled back to v0.14.5 from v0.14.15 from Releases · obsidianmd/obsidian-releases · GitHub and it seems OK for me as well; v0.14.5 also has the issue.

FYI: For now, I have not encountered this issue in Obsidian v0.16.0 :blush:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.