Citations plugin zotero

What I’m trying to do

when I add a new citation to Zotero and I then want to add this new citation to one of my notes in obsidian using the Citations plug-in it doesn’t get automatically updated and I always have to re-paste the path of the library to get it to work. I do however export the library and click to ‘keep updated’, so why is it doing this?

Things I have tried

I have tried re-exporting the Zotero JSon collection (set to auto-update) and re-pasting database path in the citations plug in.

When I make a change in my Zotero collection it doesn’t appear to update the collection auto-export so I have to go in to preferences and select export now option. I then have to go in to Obsidian>Settings>Citations plug in and re-paste the path for the reference to finally be updated.

What am I doing wrong?

1 Like

Have you tried using BibLaTex? That’s what I have been using and have had not problems at all.

I tried with Better BibLaTex and it still doesn’t work, I can’t see a ‘refresh’ button on obsidian, so I’m not sure if maybe I need to refresh obsidian when I add a reference? I tried exporting the library with BibLaTex but there’s not option to ‘keep updated’ so not sure whether this is a good option.

Maybe this has to do with your Zotero version or with Better BibTex needing an update. I am on Zotero 6 and I do see the “Keep updated” option under Better BibLaTex. Alternatively, you can try to use BetterBibTex. To be honest, I don’t remember which one I used for the citations plugin since both produce a .bib file.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.