Chinese IME broken on indented line

Steps to reproduce

  1. create a new file.
  2. type two lines, the second line is indented by two spaces.
  3. move cursor to the beginning of the first line.
  4. open Chinese IME and type some character.

Expected result

Chinese can be entered normally.

Actual result

The IME stop after typing several characters.

Environment

I have two computers, one installed ubuntu 20.04 and the other installed windows 10. The bug appeared on both computer.
The IME on ubuntu is fctix, and the IME on windows is microsoft pinyin.
I don’t use third party plugins or custom CSS.

  • Debug info1:
    SYSTEM INFO:
    Obsidian version: v1.0.3
    Installer version: v0.15.9
    Operating system: #58~20.04.1-Ubuntu SMP Thu Oct 13 13:09:46 UTC 2022 5.15.0-52-generic
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 1
    Restricted mode: on
  • Debug info2
    SYSTEM INFO:
    Obsidian version: v1.0.3
    Installer version: v0.14.5
    Operating system: Windows 10 Home China 10.0.19043
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 1
    Restricted mode: on

Additional information

screen recording
https://drive.google.com/file/d/1SEfcLyjbwCtrKP5d4mIuMa82vv9eKc3o/edit

download and reinstall obsidian, post a screen recording of this happening on windows in the sandbox vault. thanks!

I posted the recording in the thread. https://drive.google.com/file/d/1SEfcLyjbwCtrKP5d4mIuMa82vv9eKc3o/edit
I reinstalled obsidian and the problem still exists.

I can reproduce this, on MacOS.
Nov-08-2022 00-20-47

Replacing the 2 spaces with tab will also reproduce the issue.

2 Likes