Chinese character selection bar jumping around (mac)

Steps to reproduce

  1. launch Obsidian
  2. start typing with Chinese input method (either mac built-in Chinese input source or Sougou)

Expected result

The Chinese character selection bar appears right under the latin alphabet

  1. in the case of Sougou (aligning with “1”)
    截屏2021-01-11 01.02.21
  2. in the case of mac built-in Chinese input source (aligning with the 1st character)

Actual result

there can be 2 kinds of anomalies in terms of the position of the Chinese character selection bar:

  1. vertically, it may appear half above the latin alphabet, or it may appear right. The vertical position is fixed within a relaunch, and may change between relaunches.
    When it’s wrong, it’s like this:

  2. horizontally, it may appear right, but more often than not the selection bar is in the wrong place.
    The first typing after relaunch is usually correct horizontally, but then when you type within a line or between lines the selection bar appears all over the place.

    This occurs after clearing all the lines and start typing:

The exact bug happens with mac built-in Chinese input source. The screenshots are omitted due to the upload restriction.


  • Operating system: mac OS Big Sur (11.1)
  • Obsidian version: v0.10.6

We have know problems with the Sougou system. But the mac built in should work, can you post screenshots with it?

what’s your installer version? Are you using a custom css or third party plugins?

The issues with the mac built-in are the same with those of Sougou. Actually I haven’t found other issues with Sougou.

the installer version is v0.10.6 (I’ve re-installed the app, and before that it was v0.10.1 and the bug was the same). I’ve disabled custom css or third party plugins.

Actually I’ve found the pattern after a line break : the longer the line is, the more dramatic the moving of selection bar would be at the start of the next line. But within a line, it still happens the moving of the bar, but it’s more erratic and subtle, and I couldn’t find a pattern.

I’ve tried yet another input method (rime/squirrel) and the bug is also replicated. I can confirm this bug is common to all Chinese input methods.

Other electron apps (eg. vscode, typora) and all the mac based apps behave normal in this regard.

The phenomenon of selection bar jumping around also happens on the codemirror webpage. Seems that it’s a bug of codemirror.

I‘d like to give my 2 cents on this issue.

Mar-09-2021 13-34-40

There is a misalignment between the position of cursor and the Sogou candidate-word bar when the position of the cursor is just changed. The change of the position of Sogou candidate-word bar is one step later than the one of the cursor.

Hope this is helpful for locating the problem.

let me know if this is this better in 0.11.7

Hi, I think it is not solved in 0.11.7.

And this lag can also be reproduced with the MacOS build-in Pinyin input method.

I did a few more tests on this issue:
the lag only happens when I cancel/interrupt the current input (e.g by pressing ESC).

Mar-15-2021 12-56-10

Mar-15-2021 12-56-42

In case I finish the input, everything goes fine.

Mar-15-2021 12-57-55

Mar-15-2021 13-04-32

This lag does not happen in the other applications, such as the build-in Memo, so I suppose this may be an Obsidian-specific issue.

Mar-15-2021 13-01-56