Checkboxes only rendering as bullets

Once you’ve done the above, delete everything above this line.

Steps to reproduce

create a check box - [ ]

Expected result

You should see a checkbox

Actual result

It renders a bullet with a box next to it


  • Operating system: MacOS
  • Debug info:
    Obsidian version: v1.1.9
    Installer version: v1.0.3
    Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:15:52 PDT 2022; root:xnu-8792.41.9~2/RELEASE_ARM64_T8112 22.1.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: adapt to system
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 4
    Plugins enabled: 1
    1: Templater v1.16.0

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I previously didn’t have any issues with checkboxes until I updated.

Screen Recording 2023-01-10 at 12.45.30 PM-1

A few things to check:

  • Are you in Live Preview? (looks like it, but double check)

  • On a blank line, does cmd/ctrl+P and Toggle checkbox status give you a checkbox?

I don’t think this matters for your problem, but it’s recommended that you update your installer.

I’m pretty sure only one of those should produce a checkbox. You need a space between the brackets or they don’t convert.

1 Like

Yeah, the clip is blurry and the spacing is hard to see, so I hesitated to say. The forum mangles some uploads, so no fault of @tquinn35 for the image.

i’ve tried it with a space. I used to be able to make checkboxes so i know how, it just doesn’t work anymore. It formats it right away when you make the space.

Looking closely and watching the animation, they all have a space between the brackets except one that has two.

I thought I confirmed the behavior on MacOS 13.1 / Obsisian 1.0.3 (for typing only, command worked fine), but it turned out I just needed to add a space after the second bracket.


Yeah, if you type/paste - [ ] and hit ↑ or ↓, it doesn’t render. You need a space after the second bracket. I don’t think this is new.

That was it thanks.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.