Checkbox deadens macOS

Things I have tried

  1. I am on default Theme
  2. I turned off all Community Plugin, Restricted mode.
  3. Restarted Obsidian

What I’m trying to do

Was tempted to enter this into Bug but chose Help instead as I think the issue could be with me as I am new.

I have started learning Obsidian and markdown for a few days. I have made several notes already and was watching a video going through the Markdown syntax. I came across checkboxes. An hour or so later, I find myself here.

I have discovered with the issue of Version 1, some changes have been made. I have no problem with command + L or whatever I use to set this up. I am just happy to have learned I can at least now make a checkbox. However, the problem now is once I have a checkbox and then type Enter to go next line, the box disappears. Also, I can only make one checkbox…I can’t do a row or column. This problem ultimately ends my document if I want a checkbox, even if just one.

Question: Is this a bug or do I need help?

(edited for grammar)

Are you in live preview or in pure source mode?

Check the triple dots menu up in the right part of your window, and if necessary check the Source mode item. This’ll change to the purest source mode, where all your markdown shows. Within live preview, some markup kind of disappears occasionally when replaced with their preview variants.

Does this help?

If not, could you take a screen shot of your issue, and describe what you’re trying to do?

1 Like

This is normal. If the list is empty, hitting enter removes the bullet or checkbox. This is how you can quickly end a list, by hitting enter twice.

If you add content to the line, it shouldn’t remove the bullet.

If you need empty bullets for some reason you can try to turn off “Smart Indent Lists” in the Editor settings. That might disable that feature.

Or you can first add lines below. Add the checkbox. And then hit “down” instead of Enter.

As for columns of checkboxes, I am not sure what you mean, but I don’t think that is supported.

2 Likes

I was ignorant of an important detail. I am new to all this and was approaching the checkbox as if it were a separate element. I should have realized along with the checkbox, I should have added some text. Once I added text after the checkbox, I was able to continue to add more lines. The deadened was no more. Sorry to have wasted your time. Thank you very much for your suggestions.

I was in Live Preview. I will remember this about Source mode in the future.

I was ignorant of an important detail. I am new to all this and was approaching the checkbox as if it were a separate element. I should have realized along with the checkbox, I should have added some text. Once I added text after the checkbox, I was able to continue to add more lines. The deadened was no more. Sorry to have wasted your time. Thank you very much for your suggestions.