Changing default-url-scheme prompts every time in XFCE

Steps to reproduce

I’ve got Xubuntu (Ubuntu) 20.04.5 LTS, Xfce 4.14 and Obsidian installed via snap: sudo snap install --dangerous obsidian_0.15.9_amd64.snap

Every time I start it it prompts: “Allow snap “obsidian” to change “default-url-scheme-handler” subproperty “obsidian” to “obsidian_obsidian.desktop” ?” and this behavior doesn’t change after clicking yes.

If I run it by terminal:

$ obsidian 
2022-10-03 09:04:36 Loading main app package /snap/obsidian/x1/resources/obsidian.asar
Error org.freedesktop.DBus.Error.Failed: cannot set "default-url-scheme-handler" subproperty "obsidian" setting: xdg-settings: default-url-scheme-handler not implemented for xfce
Gtk-Message: 12:04:39.256: Failed to load module "appmenu-gtk-module"
[9732:1003/] Failed to call method: org.freedesktop.DBus.ListActivatableNames: object_path= /org/freedesktop/DBus: org.freedesktop.DBus.Error.AccessDenied: An AppArmor policy prevents this sender from sending this message to this recipient; type="method_call", sender=":1.214" (uid=1000 pid=9732 comm="/snap/obsidian/x1/obsidian --no-sandbox --enable-c" label="snap.obsidian.obsidian (enforce)") interface="org.freedesktop.DBus" member="ListActivatableNames" error name="(unset)" requested_reply="0" destination="org.freedesktop.DBus" (bus)
2022-10-03 09:04:39 Checking for update using Github
[9824:1003/] InitializeSandbox() called with multiple threads in process gpu-process.
WARNING: Kernel has no file descriptor comparison support: Operation not permitted
2022-10-03 09:04:39 Success.
2022-10-03 09:04:39 Latest version is 0.15.9
2022-10-03 09:04:39 App is up to date.

Expected result

No prompts after second run.

Actual result

It prompts every time I run it.


  • Operating system: Xubuntu (Ubuntu) 20.04.5 LTS, Xfce 4.14

Additional information

~$ xdg-mime query default x-scheme-handler/obsidian
~$ xdg-settings get default-url-scheme-handler obsidian
xdg-settings: default-url-scheme-handler not implemented for xfce
~$ grep -i obsidian ~/.config/mimeapps.list

Moved to help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.