Changes to CSS files do not render those changes to snippets or themes in Ubuntu 20.04

Having seen the most recent release notes that the new insider build will no longer support the Apply Custom CSS setting, I have been trying to migrate my custom theme across to my .obidian/themes folder. If I do this my theme initially loads, however if I then make any changes to the CSS files and save, those changes do not affect any changes in the appearance of my vault. This means that I am unable to edit the style of my vault real-time.

Steps to reproduce

  • In appimage install on Ubuntu (maybe Linux in general but not tested), place a theme in in the .obsidian/themes folder.
  • Select that theme from the appearance settings.
  • Change the value for a CSS property in text editor of choice and save that file.
  • Check Obsidian to see that that change has not affected the appearance of the application.

Tests done

  • I have tested this on Windows 10 and any changes to the CSS themes or snippets cause appearance updates real-time.
  • I have tested this on someone else’s vault that I had access to.
  • I tested this on a completely blank vault with no third party plugins enabled.

Expected result

I expected to see the appearance of my vault change real-time as I updated the style of my CSS snippets or themes files.

Actual result

By changing the values for CSS properties and saving, the appearance of the vault stays frozen. I can make the changes visible by saving those changes to a new file name and then activating those changes by reloading the themes or snippets folders and enabling them as a seperate file. However, this is time-consuming and prevents me from doing effective editing. The changes to the CSS also render if I reboot Ubuntu.

Environment

  • Operating system: Ubuntu 20.04
  • Obsidian version: appimage

Additional information

Update

It’s not actually as bad as I thought as, rebinding the hard refresh the app forces the changes to render but this involves a lot of reloading and is certainly not as seemless an experience as it is on Mac or Windows.

Thank you

Is is possible that is a problem with appimage or Ubuntu? have you tried snap or flatpack, does it happen there too?

I can confirm this behavior on Manjaro, using .appimage. I’ve never tried the other two installations, since other than this the .appimage works flawlessly for me.

I lived with reloading while I was setting up my theme, thinking it was a Linux bug. It could definitely be related to the installation package/method though.

Also have you tried downloading the latest appimage?

Same thing with the appimage on Manjaro for me. Installer version 0.12.3, I’ll have to check whether a newer installer changes something.

I am unsure about flatpack but I was having some issues with the snap so was unable to test this specifically for that. But yes I have installed the latest appimage and tried uninstalling it and reinstalling it both manually and with an appimage package manager installer.

Looking at the other responses, it could be that it is specific to the appimage more broadly and snap might not encounter this problem. I can do some digging on how to sort out my snap issues in the meantime but I would rather have Obsidian installed as an appimage. I just find it to be much cleaner.

I can also confirm this is happening to me on Ubuntu 20.04 (flatpak).

Also, a few questions:

  • what do you mean by “rebinding the hard refresh the app” - are you talking about “Reload app without saving”? I tried that one and it didn’t seem to pick up my CSS changes. I didn’t see any other hotkey options that are similar to what you mentioned.
  • Also, the .obsidian/snippets CSS functionality is going away? I can’t seem to find that in the release notes

Yes, so If I change some CSS in a text editor, save and then press my hotkey for “Reload app without saving”, my changes to CSS are picked up. The same thing happens if I close and restart the application.

Maybe flatpak is even worse on this issue that appimage, but I’m not sure. I’ve learnt to live with it because for any minor changes I can refresh and fetch those changes (albeit with a bit of a delay). But I have dual-boot, so if I do need to work on the CSS for a while for some reason I just boot up into Windows and do it on there. It is quite annoying though and would not be workable if my experience of it was as bad as yours.