Change time zone

i cant change timezone in obsidian. help please


Obsidian should follow the time zone of your operating system, so I don’t think you can change it for a given vault. That is beside doing some magic when starting Obsidian, possibly.

Which operating system are you using? And why do you want to change away from your default time zone?

1 Like

i have windows 10, and the operating system have the correct time, only obsidian doesnt change the time.

That sounds very strange. How do you display the time? Where does it produce the wrong output?

Is that through some plugin output, or something like that?

For me it displays the correct time in most of the plugins I’ve used, and/or daily note templates and so on.

All the plugins have the same time but in my computer is 15:24.

Not necessarily related to this but I remember having a similar issue when I first started out dual-booting Linux and Windows (the latter was one hour behind Linux but nothing to do with Obsidian). Something to do with the internal clock. One line of code in Linux fixed it (taken from the net).

Are you from Mexico? I’m having the same problem.


Having the same problem here, obsidian time is 1 hour ahead.
Running linux and being in Mexico (in case that is relevant lol).

1 Like

It seems to have to do with the elimination of Daylight Saving Time. I have had problems since the beginning of April, which is when the time had to be changed. There are people who have presented problems with devices and apps.

It seems to be that, do you know any workaround?

I’m also using linux, using templates or anything seems to be using the old system.

Has any one find a fix or a workaround?

Ok so I have made a little bit of research it appears that obsidian uses the library of moment for the devs this is the link when I run this on my Pc I can see that my pc has one time but moment runs another

1 Like

I guess they can use something like

var m = moment();
m.set({h: 11, m: 11});

So they can set the time manually form obsidian and add it to the source code of the app but it looks to complicated

1 Like

At least for me it seems that it is already solved with the new update.

I am in the same situation.
I tried reinstalling Obsidian several times, but this problem haven’t fixed.
So, I verified it according to the debug guide.
Plese let me know how to fix it.


  • Windows10 Pro 64bit
  • ver:21H2
  • Obsidian v1.2.7 for win10 64bit



Obsidian Settings

  • Core plugins
    • Enabled
      • CommandPallet
      • Templates
    • Disabled
      • Others
  • Community Plugins
    • Restricted mode is enabled
  • Vault
    • Sandbox Vault

Expected result

expected value → 2023-05-08-23:03

Actual result (wrong)

actual value-> 2023-05-08-14:03


Sorry, I didn’t see this comment.

I also checked but, i coudn’t.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.