Change spell checker language

Hello,

According to the release notes, it is now possible to change the language of the spell checker in v0.13.7:

Can someone point me at the option to change the spell checker language (to en_gb)?

Things I have tried

  • Looking through options dialog box.
  • Searched in the help vault.

What I’m trying to do

Change the spell checker language.

same problem… on macOS … i write in italian, but spellcheck is default to english, can0t find a way to change that

Yeah, same here… Would love to change it to German. Don’t get it how to do it.

As written in the release notes, it works a little different in macOS.
Obsidian uses the system-wide spell checker. You can change the System Preferences, click Keyboard, then click Text. By default, it should automatically detect the language. Works fine with me, switching between German and English.

Any suggestions on what the steps are for Windows / Linux users?

Seems that in v0.13.7 it is still not possible to do:
In Preferences, when switching language to German under ‘About’ and going back to ‘Editor’, the text next to the spell checker toggle button reads in German that ‘currently this is only working for English’.

Thanks for the suggestions here, but whatever I do the spell checker only does work in English. How do I change the language? In obsidian it seems not possible, if I change it in Mac OS X Stings (keyboard settings), it has no impact on Obsidian…

Fixed for Windows in v0.13.8:

Same in Mac OS X. It`s working

I am on the latest insider built 13.16 on a mac.

I write in German, my mac system settings are in German as well. Obsidian langue in the about section is English. I tried to change it to German, but spell check is still in English. Any ideas?

Is it possible to get german spell check when using display language in English in the about section?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.