Certificate on Cloud Flare is not resolving [Publish]

Intro to my problem:

I’m using Obsidian Publish and bought domain via namecheap. I do have problem with DNS certificates on my custom domain

Steps to reproduce

I configured DNS based on the instructions for setting up custom domain in Help Obsidian. I’m not going to copy paste it since I did everything step by step as it is in noted in doc.

Expected result

Website would work and show documents on learn.nftstandards.wtf . It worked when I used publish.obsidian.md domain. As soon as I switched to custom domain I started to have troubles with certificate.

Actual result

Error with certificate.
I waited until it processes for more than 48 hours, tried to use different settings but it seems like the issue is on the Obsidian side which seems to be problem with Obsidian Publish servers. My main domain nor my subdomain works.


I’m using MacOS Big Sur and Google Chrome browser. I tried using Safari browser but run into the same issues.
Old domain: https://publish.obsiidian.md/nft-graph
Subdomain: learn.nftstandards.wtf
Domain: nftstandards.wtf
Current DNS setup:

Configuration setup:

Is there a reason you have it set to ‘DNS only’?

What are your encryption settings?

Why are you redirecting all subdomains to obsidian if you only want learn?

I going to move this thread to help section as I don’t think there is a bug here.

Then in Obsidian help guide / tutorial should state that it should be proxied only as with DNS only it doesn’t works.

The reason why I set it as DNS only is as I make changes to the docs often and I would like to reflect changes ASAP on the website. Which with proxied it takes time to reflect changes that are made in the doc.

In the Help documentation it should be stated in the page rules to add domain name without “www” and also that it works only when the proxy status is “Proxied”.

I managed to solve this issue kudos to @yangwao :clap:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.