Case-sensitive search operators

Seems like a regression of Accept capitalized search operators - #2 by CawlinTeffid

Noticing this on Android 1.4.16 because my phone auto-capitalizes the first letter

1 Like

Thanks for reporting, but please follow the bug report template.

This was discussed on Discord.

I was able to reproduce in my main vault on iOS and Mac. In the sandbox vault or a plugin-less vault on mobile the search is still broken but doesn’t show the error message.

Here’s my iOS debug info. I’m not at my Mac right now but I’m on Sonoma and the plugin selection is similar.

Operating system: ios 17.1 (Apple iPhone)
Obsidian version: 1.4.16 (114)
API version: v1.4.16
Login status: logged in
Catalyst license: none
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: none
Snippets enabled: 34
Restricted mode: off
Plugins installed: 43
Plugins enabled: 16
1: Periodic Notes v0.0.17
2: Folder Note Core v1.3.5
3: Shortcut Launcher v1.0.1
4: Regex Find/Replace v1.2.0
5: Reveal Active File Button v2.0.3
6: Smart Random Note v0.2.1
7: Smart Typography v1.0.18
8: Sort & Permute lines v0.7.0
9: AidenLx’s Folder Note v0.16.5
10: Calendar v1.5.10
11: Tag Wrangler v0.6.1
12: Stille v1.3.4
13: Text Format v2.2.8
14: Word Sprint v0.2.5
15: Dice Roller v10.1.2
16: Text expand v0.11.4

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Some bugs are just minor inconveniences, but when you encounter them ten’s of times a day, the pain can feel like death by paper cuts.

On the iPad and iPhone, the text box for specifying a search in the obsidian vault defaults into a mode in which the first letter is auto-capitalized. Unfortunately, though, the prefixes for searches, e.g. file: are case dependent. Therefore when you want to do a search across files (or tags, or on lines, etc), you have to do some hacky workaround. For instance, I write out “Ffile:foo” and then go back an manual tap to delete the auto-capitalized first letter.

Instead, I think it would be nice of search prefixes were not case dependent to be all lowercase.

Or, you can signal to iOS that the text box should not autocapitalize the first word. In fact, on MacOS it works as you would expect.

Steps to reproduce

  1. On an iPhone, go to the Search function on the left sidebar
  2. Type: “file: foo”, see how it auto-capitalizes the prefix to be “File:”

Did you follow the troubleshooting guide? [Y/N]


Expected result

I expected to see either a) the search prefix to be case independent (i.e. support “File:foo”), or the prefix to not auto-capitalize


Happy to provide Environment details, but this is pretty straightforward - and has been a problem for many many versions.

this should be fixed in 1.5.4

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.