Canvas Zoom on Mouse Wheel


I am unable to get mouse wheel to zoom in canvas, despite changing the setting in the Canvas settings. When I change the setting, the Canvas help updates the hotkeys, but the application doesn’t respond as expected.

Steps to reproduce

1. Windows 10 Mouse Settings:

Windows open mouse settings set mouse to scroll Multiple lines at a time

2. Change settings

Settings → Canvas → Default Mouse Wheel Behaviour := Zoom

3. Canvas

Create/Open canvas
Check Canvas help to see that shortcut keys are updated:

Try to zoom in and out using scroll wheel.

Did you follow the troubleshooting guide? Yes

Expected result

I would expect the Canvas to zoom in and out using the mouse scroll wheel

Actual result

Canvas panned up and down

I noticed this when creating a new canvas yet the Canvas Help is as above.


Obsidian version: v1.3.5
Installer version: v1.3.5
Operating system: Windows 10 Home 10.0.19041
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

Changing Windows mouse settings to scroll One screen at a time allowed the Canvas zoom to work, but the zoom stops were too large to be useable, and I don’t like this behaviour on other apps.

If I flick my scroll wheel (i.e. scroll very quickly) the canvas will pan and zoom.

I’ve tried to see if I can reproduce the issue on another machine but I am not experiencing the same issue on two other Windows 10 machines.
I’ve changed mouse, tried to update mouse driver.


If you can’t reproduce with other windows computer, that’s a problem specific to that computer. I don’t think we can help you. Sorry.

How is it that the minimap zooms without issue, but the canvas fails to work?

Do you have any other suggestions on what I can try?

I can reproduce this on my end, or at least something similar. I’ll create a separate thread if need be.

Setup: 2 monitors, one 1080p, the other 4k at 200%

The scroll-to-zoom works fine on the 1080p monitor, but moving it to the 4k monitor, it reverts to scrolling up and down. Moving it back to the 1080p monitor fixes it.

Let me know if you need more information.

1 Like

My PC is a 4K monitor with scaling set to 200%. (OS is Windows 11)
I get the same symptoms on my PC.

(I also had the same zooming when I rotate the mouse wheel very quickly)

When I set the scaling on the 4K monitor to 100%, I could zoom in and out with the mouse wheel.


YES!!! That’s exactly the cause of the issue.

If you set the monitor scaling to 200% is stops zooming correctly and reverts back to panning.

@WhiteNoise please can you see if you can replicate this behaviour, by setting the monitor scaling to 200%.

I can’t reproduce this. Post a screen recording of this happening in the sandbox vault.

1 Like

Hello. Thank you for your support. I have recorded the screen and posted it. Please check it out.


Thanks for posting this. My experience is precisely the same.

I have been postponing upgrading Obsidian since v0.12, hoping to give it time to make things right.
Now I have updated to Obsidian v1.4.13, and sadly they haven’t even managed to make the only new core feature settings work. What a shame.

I can confirm, on 1920*1080 2nd monitor this setting works, mousewheel zooms.
But when launched on 4k 200% windows10 retina monitor, it scrolls instead of zooming. Just moving window between monitors instantly changes this behaviour too. A bug. Still. Should I have waited few years more?