Canvas: “set background ” button not showing background images

Steps to reproduce

・Click on the “set background ” button
・Select One of images

Expected result

・ I would expect the background of group to show the image selected (see video below)

Actual result

・ Nothing happens when I click the “set background ” button (see video below)


  • Operating system:
    edition Windows 11 Pro
    version 22H2
  • Debug info:
    Obsidian version: v1.1.13
    Installer version: v0.15.9
    Operating system: Windows 10 Pro 10.0.22621
    Login status: logged in
    Catalyst license: insider
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Typewriter v2.1.3
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 12
    Plugins enabled: 0

Additional information


Can you post a screen recording of this happening in the base theme and in restricted mode?

Also when it happens do you get errors in console (ctrl-shift-i → console tab)

I tried in the base theme and restricted mode, but unfortunately the bug happened (see video below)

Where is your vault stored exactly?

does it happen in the sandbox vault?

F1->open sandbox vault/

I also suggest you to download and reinstall Obsidian from the website. You don’t need to uninstall first.

In the sandbox vault, the button worked correctly. The bug didn`t happen and an image selected showed up on the background of group as I expected.

My vault is stored in my local folder( C:\Users\××(my user name)\OneDrive\Documents\ ).
Even though I tried to move my vault to an another folder(C:\Users\××(my user name)\Documents\ ), the bug happened.

The bug may be related to one drive (the files are not local) or maybe something weird in the path name (cjk?!?).

If you can make it happen in the sandbox vault, let me know the exact steps.

As I said in the previous comment, I moved my vault to another folder(not One Drive) but the bug happened.

Actually, I had set One Drive feature off, so i think my vault have been restored in local.
Also, The addres my vault is restored in is of alphabet (not using cjk).

Let me know if this happens in 1.1.14.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.