Canvas note duplicates not syncing changes properly

Once you’ve done the above, delete everything above this line.

Steps to reproduce

  • Create note
  • Add a checkbox to note by typing “- [ ]” or “* [ ]”
  • Add note to canvas
  • Add note to canvas again in a different spot
  • Tick the checkbox
  • Untick the checkbox

Expected result

The checkboxes should sync so that both are unticked on the two nodes of the note

Actual result

The checkboxes correctly sync when ticking them, but do not sync when unticking them


  • Operating system: Linux
  • Debug info:
    Obsidian version: v1.1.9
    Installer version: v1.1.9
    Operating system: #1 ZEN SMP PREEMPT_DYNAMIC Wed, 21 Dec 2022 22:27:59 +0000 6.1.1-zen1-1-zen
    Login status: not logged in
    Insider build toggle: off
    Live preview: off
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 1
    Restricted mode: on

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.

Additional information

This issue does occur with restricted mode on, however I was not able to reproduce it in the sandbox.

Me neither.

Try no theme/restricted mode/restart obsidian.

Try to move your vault somewhere else.

Issue still occurs after turning on restricted mode, switching on the default theme, restarting obsidian and then moving the vault folder to another location (I’ve also tried moving it to a different physical disk).
I have noticed that the duplicate notes will properly sync if I close the tab with the canvas in it however. So I can:

  • Duplicate note
  • Tick box
  • Untick (it will be unsynced here, one version will have the tick and one won’t)
  • Exit canvas
  • Re-open canvas (notes are now synced)

So that’s a workaround for now.

if you find reproducible steps in the sandbox vault, let us know.

Will do.

ok, i found it.


Yep that’s the issue. Out of curiosity; what was the other step you did to get it to work?