Canvas: Error on drag and drop from file explorer

Steps to reproduce

  1. create a new canvas
  2. Create a single card on the canvast
  3. Create a Header in the card ‘# this is a header’
  4. hit return and type a '- ’ to create a bullet point
  5. drag a note from your vault to the bullet point; so far, so good
  6. hit return to create another bullet point you’re going to drag a note to.

Expected result

Hitting return should have taken you to the next line, created a bullet. It doesn’t

Sometimes it was adding the 3rd link that caused the problem.

I also saw one case where the entire obsidian display went black. I can’t reliably reproduce this, but I’ve seen it twice. The only solution I found to this was to kill obsidian and restart it.

Also, in the original problem, if I restarted obsidian then I could hit return and would get the expected new line with bullet.

My sense is that maybe it popping back into read mode (as opposed to edit mode) on the card too soon. I should have to click outside the card on the canvas for the mode to change. It can’t be because I just hit return.

Actual result


  • Operating system: Windows 11 (latest)
  • Debug info:
    Obsidian version: v1.1.2
    Installer version: v0.15.9
    Operating system: Windows 10 Pro 10.0.22621
    Login status: logged in
    Catalyst license: insider
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 3
    Restricted mode: off
    Plugins installed: 72
    Plugins enabled: 49
    1: Tasks v1.19.0
    2: Templater v1.16.0
    3: Dataview v0.5.47
    4: Calendar v1.5.10
    5: Advanced Tables v0.18.0
    6: Kanban v1.5.1
    7: Excalidraw v1.8.4
    8: Admonition v9.0.5
    9: Outliner v4.1.1
    10: Mind Map v1.1.0
    11: Natural Language Dates v0.6.1
    12: QuickAdd v0.7.0
    13: Periodic Notes v0.0.17
    14: Advanced Mobile Toolbar v1.8.0
    15: Annotator v0.2.8
    16: Banners v1.3.3
    17: ExcaliBrain v0.1.11
    18: Highlightr v1.2.2
    19: Homepage v2.4.1
    20: Minimal Theme Settings v6.1.0
    21: Note Refactor v1.7.1
    22: Quick Switcher++ v2.3.4
    23: Recent Files v1.3.5
    24: Spaced Repetition v1.8.0
    25: Auto Link Title v1.2.5
    26: Dynamic Table of Contents v0.0.27
    27: Style Settings v0.4.12
    28: Find orphaned files and broken links v1.8.0
    29: Tracker v1.10.9
    30: Emoji Toolbar v0.3.2
    31: Status Bar Pomodoro Timer v0.1.13
    32: Buttons v0.4.19
    33: Folder Note v0.7.3
    34: Workspaces Plus v0.3.3
    35: Tag Wrangler v0.5.5
    36: DB Folder v3.0.1
    37: Hotkeys++ v0.2.7
    38: Map of Content v0.1.0
    39: Omnisearch v1.9.0
    40: PlantUML v1.6.6
    41: Better Command Palette v0.14.0
    42: Local images v0.14.2
    43: Fullscreen mode plugin v0.1.2
    44: Projects v1.3.0
    45: Longform v2.0.0
    46: Dialogue v1.0.2
    47: Plugin Update Tracker v1.4.3
    48: Obsidian Git v2.13.0
    49: Multi-Column Markdown v0.7.6

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

This is what I’m trying to generate:

When the return get’s “stuck”, the last item in the list is showing the double square brackets and cursor blinking afterward.


That’s probably a better title. Thanks for the assist.

One more thing i noticed. When I got into the state described above (return didn’t do anything), if I close obsidian down and then reopened it. Then I could click return. Feels like a state problem (probably related to whether the code thinks we’re editing or not).