Can't write under the image in file in Mobile App



Obsidian Mobile version: v1.4.2 (last)

Hi everybody!

I don’t sure that this is a bug but its very strange. When you add a picture to file in mobile app - you can’t write anything under the picture - you can only above.

Is it only my situation? Maybe i just do something wrong?



What happens when you try to select below the image?

(Tip: on iOS, you can hold the spacebar to make the keyboard into a trackpad, and then move your cursor to where you want. This works across the entire OS — on every app.)

1 Like

Ryan, thanks for answer!

What happens when you try to select below the image?

Unfortunately just nothing. Really nothing happens.
And i tried your advice - it doesn’t work too… or i do something very very wrong. I really can’t put cursor below image every time i add image.

Of course i can do this in Source mode.
But this is very strange UX pattern - change edit mode from visual to source just for putting cursor below. It can’t be idea of Obsidian’s devs i think.

Here - - i upload screen recording of my typical torment with mobile app and images…)
May be it can help…
And on video by the way there is a moment when i try your advice… and again, nothing… :sob:

Can you try with the default theme (Settings > Appearance > Themes)?

Can you try in Restricted mode (Settings > Community Plugins > Restricted mode) and restart Obsidian?

Try those things and report back :+1:t3:

Ariehen, thank you for your time!
Tried both - no changes…((
Should i make a new video?)

By the way - can somebody share video how you’re adding image to Obsidian page and can write below it? Ideally on iPhone?
Just for motivation - and for seeing that its possible!)

Added an image already in my vault by typing ![[cir... and Obsidian auto completed it.

Yeah, i see, thanks! :+1:
I guess I incorrectly expressed my thought. Its OK when i add image somewhere in the middle of post, when there are text strings below.
But when you add image from media library in the last string? Can you write something below? Create a text string below image?

Sure, I’ll try it again.

Please post the exact steps from:

  1. Open Obsidian… :grin:

Ina test note, I was able to do it once, then couldn’t do it a second time. Seems to be impossible in Live Preview some conditions.

Two workarounds for now are:

  • Switch to source mode momentarily to add lines
  • Add “move cursor” or “move line” commands to the mobile command bar to allow you to move the caret below the image

I saw the “repro” tag, so figured you (or someone) was able to reproduce it, but I tried for about 10 ten minutes in blank notes, different vaults, imported or existing images, but I could always insert the cursor and write below the image.

Ryan, thanks again!
Yes, both approaches work! Not very handy, but it works)
i m very happy that somebody else sees that moment too and i m not crazy… mostly))

By the way - what kind is your gadget? Apple or Android?

Just ran into this. Don’t know if this will help, but… the note was created on the desktop with an embedded .png as the last line of the note. A few minutes later making a cup of tea, I grabbed my iPhone to add some text under the image. Couldn’t for the life of me get the cursor to go there. Remembered this thread.

Confirmed, both of these work! :pray:t4:


this is an upstream codemirror problem

Does it have anything to do with the tapping an image makes it full screen function? Because I would gladly forfeit that feature if it fixed this issue

Another workaround: If you tap kind of the bottom edge of the lower right corner it makes the embed text appear and you can place the cursor and add lines. It’s a little tricky to get the right spot but prolly easier with practice (I just found it now by experimenting). Scroll up so there’s some space under the image, then tap around that boundary area, aiming a toward the low side.


will be fixed in mobile version 1.4.12

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.