Can't skip forward in audio recordings [Obsidian v0.8.4 macOS 10.14]

Steps to reproduce

  1. Create an audio recording.
  2. Playback audio recording in viewer mode

Expected result

Clicking on the audio slider should skip audio to that point in the recording.

Actual result

This doesn’t happen. Clicking instead pauses the audio briefly while the left mouse button is held down.

Environment

  • Operating system: macOS 10.14.6 Mojave

  • Obsidian version: 0.8.4

Additional information

I have noticed this issue since i started using Obsidian at v0.8.2.
No OS updates in that time.
Audio recorder works very well aside from this issue.
Play pause buttons and volume slider works as expected.

1 Like

Please use the template when posting a bug report.

I can’t reproduce this on windows.

updated cheers.

are you using a custom css?

Yes i was using custom CSS and I have since removed it. This has not helped.

I should also say that loading the audio files of the older recordings into some other program (firefox web player or VLC) works fine so it doesn’t seem to be an issue with those audio files.

I have also completely reinstalled obsidian after removing obsidian from Applications and the Library/Application Support/obsidian folder.

I took some new test recordings after the reinstall. After about 5-6 seconds it seems like these recordings are fully loaded into the application and I can skip using the slider.

The recordings I took with the old install (with custom css) still don’t allow skipping. But these are much larger recordings and I don’t know if that is the reason.

It seems like it takes a long time for the linked audio file to be loaded into obsidian. See below images.

What the linked audio files look like after opening the note

What the new recordings look like after playing for ~6 sec. The file appears fully loaded and skipping works using the slider. Old audio notes do not display this behaviour after playing for at least 11 mins.

Finally I linked an mp3 file and skipping using the slider works perfectly without any loading time. m4a files from macOS voice memo app also work perfectly so that is a workaround in the meantime if anyone else has this issue.

This is probably a problem with the codec built in in electron (chrome). Maybe it will solve itself when updating to a newer version.

i have the same problem with .webm on windows 8.1
It is a codec problem, as VLC also doesnt allow me to skip forward.
Maybe the plugin could record wav instead?
Or in the settings you choose what format you want the audio to be recorded (mp3, wav, webm, m4a)