Can't scroll when dragging items in file tree in 0.10.X

Steps to reproduce

  • Open File Explorer view
  • Click and hold on a file in tree
  • Attempt to scroll the scroll wheel, the tree no longer scrolls

Expected result

  • I expect to be able to scroll the file tree while I’m dragging an item, so I can drag it to a folder that is not currently visible in the tree.

Actual result

  • I’m unable to scroll, so when I have a lot of files/folders I can’t move some files into some folders because they are too far apart in the tree to view them both on the same screen.


  • Operating system: Windows 10
  • Obsidian version: 0.10.2

Additional information

I’m almost certain this worked in 0.9.X versions, as I did a lot of file reorganizing and didn’t encounter this issue. Seems to be an issue with 0.10.X only.

1 Like

you can drag and hold. I don’t recall if scrolling worked, but we’ll look into it

Scrolling works if you drag the file to edge and wait. Or are you talking about the mouse scrollwheel? That will not work anymore.

Why won’t it work any more? It’s quite painful to drag many notes into folders when I have 1000+ notes and 100+ folders without being able to scroll with the scroll wheel. I create about 5 - 10 notes per day and they all go into the root folder until I reorganize them.

Today I was trying to reorganize and dragging to the edge didn’t even work for me. It seems pretty finicky sometimes.

I was streaming today when I encountered the bug of the sidebar not scrolling. You can see it at the 18 min mark in this video:

As you can see, it’s pretty painful to try and reorganize my notes when it’s this hard to drag them into the correct folders. It almost makes Obisidian unusable for me unless I want to keep all my notes in the root folder.

I think you just dragged it a bit too far, so auto scroll didn’t work. :sweat_smile:
Try to drag a file like this gif. It works fine on me.
how to drag

Let us know if it still doesn’t work.

I got it working again. I’d still far prefer to use my mouse scroll wheel though and would like to know why it was disabled. As this is ok for a few items and folders but quickly becomes painful when you build up a large notebook.

1 Like