Can't save existing file or create new files or folders

Things I have tried

I have searched the forum for “can’t save(/create) file” and the errormessage in forum, but nothing showed up.

I’ve just installed Obsidian but couldn’t seem anything in options to try and change that might help resolve.

What I’m trying to do

I’m trying to save an existing edited file and create new files, but get an error: FILE_NOTCREATED

I’m using Resilio Sync to sync the folder my notes are residing in. I’m not using Obsidian Sync.

I have existing notes in the folder. I can open them and edit, but get the error when Obsidian tries to save edits. The folder is synced with an android device and a macos device.

What should I try?



Tried removing conflicting files in .obsidian and .sync folder and reinstalling Obsidian, but am still getting the same error.

Had the vault folder on SD card. Just tried moving it on internal storage the errors are gone. Will try moving the existing files into the folder, to see if it’s just because of SD location.

Seems like the error is Obsidian doesn’t work with (my?) SD card.

Can create new Vaults and selevt existing folders on internal memory, but not on SD card.

Don’t know how it was possible first time.

It would be great if Obsidian had a clear errormessage or informed before selecting a folder as Vault, that it can’t be placed on the SD card.