Can't rename vault: Error: EPERM: Operation not permitted

Things I have tried

I searched the forum for my error, and didn’t find it.

What I’m trying to do

Rename a vault. When I try to rename my vault, I get the message:

Failed to rename vault. 
Error: EPERM: operation not permitted, 
rename 'D:\gdrive-bhagerty\Obsidian\test' -> 

I am using Obsidian v0.15.9 on a Windows 10 Pro laptop with all updates. If I recall correctly, I installed Obsidian using normal options. As a user, I have file permissions in the directory where my vault is located.

Sorry, but you couldn’t find the error on the forum?

It doesn’t look like there are any definitive answers in those links. But it is a permissions problem.

First of all, can you post your “Show debug info” information?

Was this folder working before, and then recently stopped? Or did it never work? Have you tested copying your vault to a different drive to see if it works there?

Is this an external drive? I notice in my external drive (which I don’t use Obsidian on), I often get major write delays because it keeps going to sleep after inactivity. Maybe that’s a clue.

I’m not very familiar with Windows IT, but maybe you need to grant Obsidian permissions to that folder. Is there a way to query permissions like in Linux/Unix?

1 Like

Thanks for the response. I did search the forum, but I searched for my use case, failure to rename a vault, not the error message. The results you found all relate to different use cases.

This is a bug of some kind, not a permissions problem, as I have permissions in the directory, which is on an internal SSD. I have no problems saving files or creating new vaults in the directory.

And in fact, the bug disappeared, and I was able to rename the vault that I previously could not rename. I suspect that there’s something wrong with the way Obsidian locks vaults that are open. If you try to rename a vault that’s open, you get an error saying you can’t rename an open vault. After I closed the vault and tried to rename it, I got the EPERM error. Today, when I reopened Obsidian, I was able to rename the vault without an EPERM error. So I will close this topic.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.