Can't remove Windows folders ("con", "test.") in Obsidian trash


I created accidentally a folder trying to put a link [[https.//]] ( . insted of : ) and https. folder was created. Then I delete the folder and keep writing, but when I was doing a backup I obtain an error from the Obsidian trash route.

After a few tests I understood the error, you can’t name a folder in Windows with a dot the end of the name, for example “Name.”. The name of Windows folders are restricted and cannot be named as “Con”, “Test-name.” which is not the case for Obsidian Vault.

So when I try to delete “https.” folder, a windows error appears:

Item not found
Could not find this item
“This is no longer located in C:\ObsidianVault.trash. Verify the item’s location and try again.”


Problem to solve

Now i’ve got various folders (because I try with other names) in the Obsidian trash that I can’t remove. I’ve tried to remove with cmd with privileges, change the name, remove manually but it gets me the same error.
If someone can help me it would be great and also notice this thing to others Windows users.


I’m using windows 10 (build 19044) with Obsidian version 0.14.16.


  • Remove all folders except CON: rmdir /s "\<full path to directory>\.trash"
  • Remove CON folder: rmdir "\\.\<full path to directory>\con"

Yes, this is is a known problem. You are gonna need to resort to console or powershell to delete that directory.

With rmdir I could remove all directories inside .trash (obsidian trash) except CON folder

rmdir /s .trash

rmdir "\\.\<full path to directory>\con"

something like:
rmdir "\\.\C:\Users\Rodja\AppData\Roaming\obsidian\Obsidian Sandbox\con"

1 Like

Thank you very much.

no problem. we’ll try to fix this ASAP.

Will be fixed in 0.14.10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.