Can't open vaults from right-click menu

I cant open vaults from right-click menu, i also cant open obsidian links in from of Obsidian:\… (they guide me to microsoft store). I think it is a problem with my OS but can’t figure what. I am using Windows 10. Please someone helps me.

1 Like

The form is obsidian://, not Obsidian:\, so that might be the problem.

I just right it from top of my head, the links are autogenerated by obsidian so they should work any way

It sounds like maybe Obsidian’s URI scheme isn’t registered with the OS. According to Using obsidian URI it should have happened automatically, but maybe for some reason it didn’t? You could look into how to do it manually and try that (or reinstall Obsidian, but that sounds annoying).

1 Like

thanks, I do usually reinstall obsidian after few updates, should i manually uninstall and reinstall it? that should not be a problem since all the data are saved in the vault, right?

I don’t know of it’s needed, but I suppose uninstalling first might be the most thorough way to do it.

It should not be a problem because your data is saved in the vault, but backup first anyway to be safe.

Were you able to open the links before? If so, can you think of anything about your setup that has changed since then?

1 Like

no, I never used such links, I also have problems with using zotero links in such format to open pdf files as certain pages, the weird thing is that this happening even after I migrated to the new laptop with a upgraded OS.

Zotero links in Obsidian or elsewhere? Like zotero://?

both, if I run (Win+R) a zotero link like zotero://…pdffile?p20 it is not going to open the specified page and only open the file (at first page) no matter what app i am using as pdf reader, I guess it can be connected to this issue

I don’t know Zotero but it sounds like the links partially work? I’d guess they’re separate problems but maybe they’re connected.

I would start by finding out if Obisidian’s URI scheme (may also be called URL scheme) is registered with your Windows (I don’t know how to check this, so I’d search the Web first). If it’s not, then you’ll want to figure out how to change that. It it is registered, then the problem is elsewhere.

1 Like

thanks, the problem is that i have no familiarity with windows registry, because of that i can search accurately for the problem. i will try again but i really hope some of devs could help me with this issue or at least had a guide for it or something

I tried to search the web but almost everything I found was aimed at developers. I finally figured something out by typing “uri” in the Windows menu.

Go to Windows Settings > Apps > Default apps and type “obsidian” in the search box. When I do this in Windows 11 I see a result card for the Obsidian app, and under the app name it says “URL:obsidian”. If you see that, it should mean that the URI scheme is registered with Windows and the problem is elsewhere.

1 Like

i did it ,but it shows only the size, version and installation date. I don’t know if it is a problem with all the apps or it is different because i am at Windows 10 not 11

I dug out a Windows 10 laptop, and the location is slightly different: Settings > Apps > Choose default apps by protocol. I don’t know what setting screen you’re looking at, but I don’t think it’s the one you want, because I don’t see size, version, or installation dates here.

In the settings screen I listed above, there is a left column called “Name” that contains entries like:

BINGWEATHER
URL:bingweather

and a right column listing an app that opens each URL type.

I installed Obsidian but I don’t see it listed there in any form, so I think Obsidian didn’t register its protocol on my laptop (but maybe I’m misunderstanding things). I made a new vault, added a file, and restarted Obsidian, and I still don’t see anything there. Do you see anything about Obsidian in that list?

1 Like

thanks, i found it, but there is not Obsidian in the list neither zotero in there (i guess the issues are related after all). now the question is how to fix it and why it is not already registered

At least we know more than we did. Hopefully someone who knows more can step in (Windows isn’t my main system; I normally only use it for a certain work task).

1 Like