Can't install Local REST API plugin

Things I have tried

I tried to install the Local REST API plugin by @coddingtonbear to then use the Obsidian Web browser extension, but all I get from Obsidian is “failed to install plugin” message.

I’ve looked in all the obvious places, and cannot find any other information about what to do.

I’m running Obsidian 0.13.23 (installer 0.12.3) on a Mac running MacOS 12.2.1.

What I’m trying to do

I would like to install the Local REST API because I want to try the Obsidian Web Chrome extension.

Can anyone suggest what I should try to do?

Oo – this is my fault. I have been working on some new additions to the REST API Plugin and hadn’t realized the Obsidian plugin installer would look at my pre-release manifest.json to determine the version of the package to download rather than just looking for the latest tagged release. I’ve updated the manifest.json to point at the current released version now; so you should be able to install the plugin again – just note that you might need to reload obsidian from the Ctrl+P menu (Obsidian might cache some things).

For other folks who come across problems like this in the future and wonder how I figured this out: if you open the inspector from within Obsidian (Ctrl+shift+i), you’ll see the web console, and error messages (like the one we’re encountering here) will be displayed there.

Thanks muchly. Will give it another try today.

Same issue for me: Version 0.13.23 (installer 0.13.14) Windows 10 so still no fix?

I’m afraid I’m not seeing any trouble installing the plugin personally; what message do you see in the console (I showed instructions above) when you try to install it?

Hi, thanks for the reply. The error showing on the console is:
Plugin failure: obsidian-local-rest-api TypeError: callSite.getFileName is not a function

I did just try to install this on Windows a moment ago, and it installed without any problems; so I’m afraid it’s really looking like whatever is wrong in your case is particular to your installation. Maybe just make sure you’ve restarted Obsidian and refreshed your Community Plugin list – I suppose maybe it’s trying to install an old version or something :person_shrugging: .

thanks for checking.

Tried all the options but no joy, shame as I was really after the Obsidian Web option for workflow optimisation.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.