Can't get footnotes to work consistently

What I’m trying to do

I’m trying to use simple footnotes, as outlined in the help:Format your notes - Obsidian Help

What happens

Sometimes (but not often), footnotes render correctly in Preview mode, but most of the time footnotes do not render or link properly. Screenshots below of both edit/previews for when it worked and when it didn’t.

In addition, sometimes it works on a page initially, then when I edit anything on that page (not just the footnote), it breaks the footnote.

Example of it working:

EDIT:


PREVIEW:

Example of it not working:

EDIT:


PREVIEW:

Configuration:

I don’t use any footnote or citation plugins
MacOS Monterey v 12.4
Obsidian v 15.6 with installer 15.6

What I’ve tried:

I can’t seem to replicate it consistently. I’ve tried removing all formatting, links, and attributes, and fiddled around with various spacings before and after links and elsewhere – but still, sometimes it works and sometimes not (again most of the time not). The only thing consistent is that once it doesn’t work on a page - it never works on that page (even if it had worked at one time).

Any hints, if I’m doing something wrong, would be appreciated, or maybe it’s a bug? Thanks!

1 Like

I think you need to add a blank line after Source::

Try that.

Wow. That simple. It worked! Thanks so much. Appreciate the response.

1 Like