Can't enable calendar plugin


I’m trying to install and use Liam Cain’s calendar plugin, but I’m running into some issues. Installation seems to go fine, however, I am unable to enable the plugin - I am repeatedly given the error message: “Failed to load plugin calendar”, as shown in the image attached.

setup information.

  • Obsidian Version 1.4.1, Android / PlayStore Release
  • Chrome OS Version 107.0.5304.51 beta
  • Using SyncThing to sync my vault with another device - and android smartphone.

what i’ve tried.

  • Tried downloading the plugin from the official github page, as well as the community plugins section within obsidian.
  • Both the latest stable and beta releases of the plugin.
  • Attempted to enable the plugin in an empty, newly created vault.
  • Tried other plugins - they install and can be enabled with no issue.
  • Clearing obsidian’s cache and user data, reinstalling obsidian, and rebooting my device.

what i haven’t tried.

  • Building the plugin from source. (I’m lazy)
  • Making a blood sacrifice to the tech gods. (I have carpeted floors)

Any ideas would be appreciated. Daily notes without the calendar are so much less convenient.

This just started happening to me today. I opened up Obsidian and it just won’t open the plugin. I tried downgrading from an insider build to see if maybe that was the cause, but it didn’t help. It stopped working on both desktop and mobile for me.

You may want to file your question as an issue at the plugin’s GitHub (if a similar one doesn’t already exist).

The plugin’s closing in on 2 years without an update, so it could just be incompatible with the way Obsidian works now.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.