Can't delete a note

Things I have tried

Posted in bugs now posting here. Right-click brings up context menu for delete. Obsidian won’t delete.

What I’m trying to do

Here my screencast of the non action: Dropbox - Riaamp- Can't delete - Simplify your life

I’m a new user. Downloaded the app again from the website… flummoxed.

1 Like

I’ve had this happen to me as well. I’m going to assume you’ve verified this isn’t an issue with file permissions.

Some things that I’ve tried to get it unstuck:

  1. Try deleting it again, but by clicking on the dots next to the file name in the Title Bar to the Editor/Viewer. Alternatively, if you have that file open you can open up the command pallette (you have to have that core plugin enabled; it’s default shortcut is Cmd/Ctrl+P) and selecting “Delete current file”.
  2. Try creating a blank file and deleting it. Assuming that works, try deleting your original file.
  3. Delete the file from your file system using Finder (MacOS), Windows Explorer (Windows), etc.

okay … that three dots method works. And of course deleting in the finder works but that seems like quite the workaround! BTW: your #2 doesn’t. But if I know that I can delete it with the three dots that’s helpful. And knowing that I’m not the only person that’s had the problem. Thanks!

I notice you’re using your “Documents” folder, which is a built-in MacOS folder. (Or maybe you just named your vault “Documents”?)

I highly don’t recommend using that folder. You should create a separate folder to be your vault. Especially because other apps will be using that folder, and you’ll end up with a mess in your vault.

I’ve also seen people have trouble when syncing on iCloud. And the ~/Documents folder is synced with iCloud (at least by default.) So it might be an iCloud bug.


  1. Make a new folder to be your vault.
  2. You might also want to consider moving that folder outside of any folder that syncs with iCloud. (But my knowledge might be out of date. Those bugs might have been fixed!)

If you want to check for more info on iCloud bugs and see if it works or not:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.