Can't create new note. No Error messages

Note: Found work around while typing this up. Please see additional info.

Steps to reproduce

  1. Ctrl-N to create new note OR
  2. Click on Create New Note.

Expected result

New Note created.

Actual result

Nothing happens. No error notifications.

Exception in console:

app.js:1 Uncaught (in promise) Error: File already exists.
    at t.<anonymous> (app.js:1:972774)
    at app.js:1:235078
    at (app.js:1:235183)
    at s (app.js:1:233922)
(anonymous) @ app.js:1
(anonymous) @ app.js:1
(anonymous) @ app.js:1
s @ app.js:1
Promise.then (async)
l @ app.js:1
(anonymous) @ app.js:1
m @ app.js:1
e.createAndOpenMarkdownFile @ app.js:1
callback @ app.js:1
yH @ app.js:1
e.executeCommand @ app.js:1
e.onTrigger @ app.js:1
e.handleKey @ app.js:1
e.handleKey @ app.js:1
t.handleKey @ app.js:1
e.onKeyEvent @ app.js:1


  • Operating system: Windows 10
  • Debug info:

Obsidian version: v0.15.9
Installer version: v0.15.9
Operating system: Windows 10 Home 10.0.19044
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Encore
Snippets enabled: 2
Restricted mode: off
Plugins installed: 21
Plugins enabled: 19
1: Admonition v9.0.5
2: Autocomplete v0.8.0
3: Calendar v1.5.10
4: Comments v0.2.0
5: Custom Frames v2.4.4
6: Dataview v0.5.46
7: Enhancing Mindmap v0.2.4
8: Natural Language Dates v0.6.1
9: QuickAdd v0.5.5
10: Reminder v1.1.12
11: Search on Internet v0.5.0
12: Templater v1.14.3
13: Todoist Plugin v1.9.0
14: Buttons v0.4.17
15: Style Settings v0.4.12
16: Tasks v1.15.0
17: Linter v1.6.0
18: Omnisearch v1.6.4
19: Hotkey Helper v0.3.15

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Searched for “Untitled” in vault, found nothing. Reloaded Vault. Nothing.
Searched for “Untitled” in Explorer. Found “” and “Untitled”. Deleted them. Now works.

Suggestion: Catch the “File exists” exception and display error message with suggestion to check the file system.

I don’t understand. if a note untitled N exists, a note untitled N+1 is created.

Yes, that’s what I was expecting as well. In this case, it just failed. And I couldn’t tell what file it was trying to create.

If you can figure out reproducible steps, let us know.

Is your vault synced with some third party sync provider? like icloud? or onedrive?
Are the files on disk or they are virtually on disk?

The files are synced with OneDrive. They are theoretically on disk.

Q: Can you point me in the direction of the JS that’s throwing the error? I can put a console log in the exception to get a better clue.

You may have enabled one of the onedrive options to download files “on demand”. SO the files aren’t really on disk at all times.

1 Like

Have toggled “Always keep on device” on. We’ll see if it happens again.

Thanks for the prompt response.

1 Like