Can't add footnote in bullet points

Steps to reproduce

Start a new note and add a bullet point with “-”. Enter [^1] to create a footnote.

Expected result

A normal footnote to be created.

Actual result

The cursor and footnote moves a few steps back and isn’t created correctly.


  • Operating system: Windows 10
  • Obsidian version: 0.6.4
  • Using custom CSS: Yes, but tried with custom CSS disabled and got same result

Additional information

Screengrab of bug



I am using the default CSS theme and I have the same issue. Same OS and version.
I should add that the rendering in the Preview shows the footnote correctly.

For some reason there seems to be a “misuse” of the syntax for footnotes. The right syntax is ^[text] and NOT [^text] . If you use ^[text] you can have a footnote related to a bullet point rendered correctly. All my footnotes done that way, incl. in bullet points, work perfectly in Obsidian.

1 Like

See lengthy discord discussion between myself and @Klaas, finishing with mutual understanding that both syntax’s are right, because there are two different ways to write footnote markup!

To me then
a) this bug, as reported needs fixing and
b) the Obsidian help files should also document the “inline” footnote markup used by Klaas

This will be fixed in the next release 0.6.5. Let me know if you still have problems.

1 Like