Cannot move/rearrange panes when running under Wayland

That VSCode issue you linked has supposedly been resolved by updating to Electron 22. I’m already using Obsidian with Electron 22 and unfortunately still have the issue.

I recently also hit this issue. I’ve been able to work around it for now by forcibly using electron21, which there was conveniently has a separate package for. Then you can just run it with

XDG_SESSION_TYPE=wayland OBSIDIAN_USE_WAYLAND=1 electron21 --ozone-platform=wayland /usr/lib/obsidian/app.asar

Ironically enough, despite the issue going back till August of 2022, 21 works for me but not 22. So I only hit the issue after obsidian updated its electron version recently.

I just tried, that doesn’t work for me. What OS are you on?

Arch, which is one of the main reasons I mentioned it ironically enough.

% pacman -Qs obsidian
local/obsidian 1.1.16-1
    A powerful knowledge base that works on top of a local folder of plain text Markdown files
% pacman -Qs electron
local/electron 22.3.3-1
    Build cross platform desktop apps with web technologies
local/electron21 21.4.3-1
    Build cross platform desktop apps with web technologies
%                                                                                                                    ~

Hmm, I’m on Arch as well and it doesn’t work for me with electron 21.4.3-1. What WM are you using?

river 0.2.4-1

Idon’know if it is directly related:

I am running Obsidian 1.1.16 (obsidian/obsidian-1.1.16.asar) under Chrome OS Version 111.0.5563.118 (Official Build) (64-bit) on a Chrombook.

I can resize a cards in an existing canvas using the bidirectional handles at the edges, the horizontal and vertical resize mousepointers are displayed but do not work.
Move does not work when the suggested mousepointer is shown.

My current workaround is to “move-by-double-ege-resize”.

A bit tedious, but hey, i am not resizing cards that often.

There is no difference between old and just creted cards.

It worked when canvas was introduced.

Same issues on debian+sway and AppImage of latest obsidian. When you go to Settings > appearance > window frame style and select native frame you will not be able to drag anything. Electron is a complete garbage when it comes to Wayland unfortunately.

Obsidian 1.2.6 will ship with a new installer (electron 24). You will need to download and reinstall obsidian from the website.
Let me know if it solves this issue.

Still the same issue here, running Obsidian 1.2.7 (installed from the Arch repository) on sway.

Tested with Electron 22 (default using the Arch package) and 24 (installing electron24-bin manually and running electron24 /usr/lib/obsidian/app.asar --ozone-platform-hint=auto --enable-webrtc-pipewire-capturer --disable-gpu).

Changing the window frame style didn’t change anything either.

Well, I don’t move panes that often, so I guess I’ll just restart Obsidian on XWayland when I need to update my setup :slight_smile:

I’ve also got the issue in NixOS with HyprLand:

	Obsidian version: v1.2.8
	Installer version: v1.2.7
	Operating system: #1-NixOS SMP PREEMPT_DYNAMIC Sun Apr 30 23:26:28 UTC 2023 6.1.27
	Login status: logged in
	Catalyst license: none
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Also, the linked vscode issue does not seem fixed yet after all with the new electron version.

ok so, we are gonna have to wait more.

1 Like

This was an upstream bug.

It was fixed here:

then backported to electron22 here: chore: cherry-pick d42c3e5fb7c3 from chromium by vially · Pull Request #38199 · electron/electron · GitHub.

vscode’s also updated to use that patched version of electron: chore: update [email protected] by deepak1556 · Pull Request #183116 · microsoft/vscode · GitHub

Just waiting on obsidian to do the same

That’s great. We don’t have the resources to cherry pick commits but eventually we’ll get it when the new versions of electron include this and we update to it.

Just to clarify, the electron version with this fix has already been released: Release electron v22.3.10 · electron/electron · GitHub

No cherry picking needed.

Yeah, but we are using electron 24 and we are not gonna downgrade for that.

Tldr eventually that patch will be applied to a new version of electron and eventually we will update to that.

We can’t rush/yolo electron updates because we have had major regression happening.

Is that a particular version of Obsidian? The fix was backported to electron 22 because the fix was already applied in every other version >= 22, including 24. I’m on Obsidian 1.3.4 and it says it’s still on electron 22.3.3.

Read the thread again.

I read it, thanks. But nvm, it looks like the arch package relies on electron 22.

Hey, I ran into the same issue - rearranging panes doesn’t work on Arch under Wayland when obsidian is installed through pacman.

Based on @NotMe comments, I installed and switched Obsidian to electron24 which resolved the issue.

Guess the resolution is just to wait for the Arch package to update, until then this is a viable workaround:

sudo pacman -Sy electron24
cat /usr/bin/obsidian | sed 's/electron/electron24/' | sudo tee /usr/bin/obsidian