Cannot log in to Obsidian Sync - Android, Pixel 4a

Steps to reproduce

  1. Install Obsidian from Play Store
  2. Open app → Grant permission to manage all files
  3. “Setup Obsidian Sync”, enter email and password (no 2FA)
  4. Press “Sign In”

When I press it, nothing happens. This is a fresh install. Similarly, when I create a new vault, and try to sign in through the plugin, that login button works, but it gets stuck on a loading spinner.

Did you follow the troubleshooting guide? [Y/N]


Expected result

I can log in

Actual result

Sign In button does nothing


    Operating system: android 13 (Google Pixel 4a)
    Obsidian version: 1.4.9 (108)
    API version: v1.3.7
    Login status: not logged in
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: on

  • can you sign in with the same login and password on the desktop app?

  • are you sure sure you are using the same login and password everywhere?

  • have you tried using wifi instead of mobile data or vice versa?

Good idea, turns out my wifi is flaking out. Switched to mobile data, it worked almost immediately. Thanks.

I do wish there was an indicator that it was doing something when I press the button, though.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.