Cannot load PDF with the new pdf viewer (API version)


What I’m trying to do

I have issues opening pdf with the new pdf viewer. It seems to be related to PDF.js.
I have the following error message:

f.viewer.min.js:22 pdf.loading_error

PDF.js v3.7.0 (build: ?)
Message: The API version "3.7.0" does not match the Worker version "2.5.207".

dex.html:1 Uncaught (in promise) UnknownErrorException {message: 'The API version "3.7.0" does not match the Worker version "2.5.207".', name: 'UnknownErrorException', details: 'Error: The API version "3.7.0" does not match the Worker version "2.5.207".'}

version v1.3.5 installer v1.3.5
On a company computer (could be the origin of the problem)

Things I have tried

Update to last built, redownload from the obsidian website.

I am stuck at the moment, do you have any ideas to solve this ?

What about the rest of the bug report template?

I started with the wrong template, sorry.
Using divide and conquer I was able to find the plugin causing the issue (was loading the wrong pdf js version)

Thanks for your reply. Solved

No worries. For next time. :wink:

If the template is filled out properly and the steps followed, it gets rid of the back and forth: “did you try with the default theme?” “did you try in restricted mode”? …and so on.

Glad it’s sorted!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.