Cannot jump to headers with spaces

Steps to reproduce

  1. Make a header with space and use the jump to header thingy. Just like this:
[Jump to me](#jump-to-me)

#### Jump to me
Good job!
  1. Click the Jump to me and It should jump on the header.

Expected result

Does not jump to the header.

Actual result

It should jump to the header.


  • Operating system: Windows 10
  • Debug info:
	Obsidian version: v0.13.33
	Installer version: v0.13.23
	Operating system: Windows 10 Pro 10.0.19044
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Safe mode: off
	Plugins installed: 3
	Plugins enabled: 3
		1: cMenu
		2: LanguageTool Integration
		3: Advanced Tables

	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

Additional information

It would be really awesome If you can jump to headers that has spaces in Obsidian(Markdown) and if the reproduce is still to little to be understood somehow.

  1. Copy and paste this Ultimate Privacy Guide by All0cation from Github to Obsidian.
  2. Click any jumpers that has space in the Contents and It won’t jump.
1 Like

As an alternative, you can use [[page#jump to me]] to get the right result. Though with that markdown document you linked, you obviously can’t do that.

If I use that, Github and other markdown stuff won’t be able to parse it. Using:

[Jump to me](#jump-to-me)

#### Jump to me
Good job!

Seems to work in and platforms such as Github, Gitlab & etc

true, there is definitely an issue, just suggesting a compromise.

1 Like

I understand anyways thank you!

This is not a big. We don’t support that format. Check out the docs.

But this feature will be really useful for people who uses Obsidian as a markdown editor for their Github & etc.

Please, search/open a feature request

1 Like