Cannot embed tiff images

Steps to reproduce

Embed a tif file into notes ![file.tif]

Expected result

The image is embedded and visible like another image format would be

Actual result

There is a box, which when clicked opens the tif in the default image viewer


  • Operating system: arch linux
  • Obsidian version: 0.11.5

Additional information

I see tiff files are supported: Embed files - Obsidian Publish.
My files are have the .tif extension. I thought renaming to .tiff might help, but does not.

Here is a screenshot:

have you tried renaming to tiff not tif

I run Obsidian 0.11.5 on Linux Mint 20.1/Cinnamon. Renaming to .tiff makes Obsidian recognize the image as valid file type (it shows up in the attachments folder). If I click it in the files pane, an external image viewing tool opens and shows it. But is is not displayed as image in preview mode, as the OP showed.

Then again, most browsers don’t display .tiff natively, so maybe this is an Electron limitation?

Yes I tried that but it did not embed. Obsidian recognises both tif and tiff, but treats them differently.

Obsidiann will attempt to display the .tiff when clicked from the sidebar, but displays just an empty frame. On the other hand, .tif files (still recognised in the sidebar) will open in external editor by default when clicked.

Thank you for checking. I believe there was a change upstream in tiff support. we might have to drop .tiff if this is the case.

I confirm that .tiff images were never truly supported.