Cannot edit fillable sections of pdf

I recently began to use Obsidian to edit a pdf, specifically a character sheet pdf for Dungeons and Dragons 5th Edition. I filled it out and saved it, but for some reason there are some issues I have trying to edit out some mistakes I made

What I’m trying to do

I am trying to be able to edit sections of my pdf, but editing it just results in it reverting back to the state it was before I entered/deleted/moved the text, like so:

Text before I try to edit:


What I change it to:

2 Rapiers

What it reverts back to after I click outside of the editable field:


But strangely whenever I try to edit fields I have not filled out, I am able to fill them out until I click on another tab, which prompts me to save the pdf, which says that it already exists and asks me if I would like to replace it, so I click yes, after which I go back to the pdf and the edit is gone

Things I have tried

  1. I have tried closing Obsidian with Task Manager and reopening it, and it still does not work
  2. I have tried making a second version of the file and editing it and it does not work
  3. I have tried deleting everything in a particular field and it does not work
  4. I have tried installing the Annotator Community Plugin as it says it lets you edit pdf’s, just to see if it would work, and it does not work.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.