Cannot convert from valid yaml to valid property type

What I’m trying to do

I had collection of values(array) in yaml inside frontmatter


workout: [0, 1]

After I change the “Properties in the document” from “source” to “visible”, the property type for work is invalid with a “?” instead of a list type. Also, I am not able to change the property type to list.

Anyone else facing a similar issue ?

The issue is that I am not able to use the new Properties UI with my obsidian tracker plugin. Previously I was writing yaml inside frontmatter with
array value as workout: [1, 0] and it worked. But I like the new properties UI and unable to use it if I choose the property type as list for key “work” in my frontmatter.

Text type does not work either.

Have you tried to use this :

workout: ["0", "1"]

… in the YAML (while in source mode) ?

Although, this will probably get reformatted as :

  - "0"
  - "1"

… once you interact with Properties.

Note that I don’t use the plugin Tracker :innocent: … So I don’t know if it’ll help :upside_down_face:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.