Cannot click to link in canvas's backlink panels

Steps to reproduce

  1. Open a canvas file with unlinked mention;
  2. Clik on the link button on the unlinked mention panel;
  3. See Error.

Expected result

  1. Unlinked mention disappeared after I click on the link button

Actual result

  1. A new unlinked mention comes.
    like screenshot below:


Obsidian version: v1.2.3
Installer version: v1.1.8
Operating system: Windows 10 Pro for Workstations 10.0.19045
Login status: logged in
Catalyst license: vip
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: light
Community theme: AnuPpuccin v1.4.2
Snippets enabled: 10
Restricted mode: off
Plugins installed: 59
Plugins enabled: 58
1: Longform v2.0.3
2: Obsidian Memos v1.9.7
3: Obsidian42 - BRAT v0.7.0
4: Pandoc Plugin v0.4.1
5: QuickAdd v0.19.4
6: QuickShare v1.3.1
7: Readwise Official v2.0.1
8: Pane Relief v0.4.1
9: Quick Explorer v0.2.8
10: Paste image rename v1.6.1
11: Outliner v4.4.0
12: Projects v1.14.0
13: Privacy Glasses v0.7.1
14: Hover Editor v0.11.9
15: Icon Folder v1.7.0
16: Lapel v0.1.0
17: Link Favicons v1.8.1
18: Double Click Tab v1.1.2
19: Export Image plugin v1.0.4
20: Footnote Shortcut v0.0.9
21: Commander v0.4.9
22: Another Quick Switcher v8.7.1
23: Better Command Palette v0.15.0
24: Plugin Groups v2.1.0
25: Canvas Mindmap v0.1.3
26: Canvas Block Reference v0.0.4
27: Latex Suite v1.6.13
28: Link Nodes In Canvas v0.0.5
29: Awesome Image v0.1.0
30: Icon Shortcodes v0.9.7
31: Auto Link Title v1.4.1
32: Better Word Count v0.9.6
33: Kanban v1.5.2
34: Floating Search v3.3.0
35: Gemmy v0.0.3
36: Zotero Plugin v1.0.2
37: Zoom v1.1.1
38: Word Splitting for Simplified Chinese in Edit Mode and Vim Mode v1.10.0
39: Webpage HTML Export v1.4.1
40: WakaTime v1.0.0
41: ToggleList v1.1.3
42: Templater v1.16.0
43: Tasks v3.0.0
44: Task Progress Bar v1.6.1
45: Tag Wrangler v0.5.8
46: Table Enhancer v0.4.1
47: Tab Switcher v0.0.2
48: Surfing v0.8.16
49: Style Settings v1.0.3
50: Obsidian42 - Strange New Worlds v1.1.4
51: Natural Language Dates v0.6.1
52: Linter v1.11.0
53: Hider v1.2.4
54: Easy Typing v5.1.9
55: Excalidraw v1.8.22
56: Dynamic Highlights v0.3.1
57: Dataview v0.5.55
58: Text Generator v0.3.3

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Seems fine for me. Obsidian v1.2.3 (1.1.16)

Have you followed the debug steps? Sandbox vault?

I reproduce it in sandbox.

It should be related to a regex problem in Obsidian. You can try to add something like:


And then create a new note named or untitled.canvas, click on the link button in backlink panel. See error.

I am not sure I understand you. Post a screen recording of this happening in the sandbox vault. I took a screen record in imgur.

OK. That’s a weird one.

OK this has nothing specific to do with canvas.
It’s this:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.