Cannot change property type

Steps to reproduce

  • Click on Property icon > Property Type > change to any other type > cannot change

Did you follow the troubleshooting guide? Yes

Expected result

  • Property Type can be changed

Actual result

  • Property Type cannot be changed


Obsidian version: v1.4.2
Installer version: v1.3.5
Operating system: Darwin Kernel Version 22.6.0: Wed Jul 5 22:21:56 PDT 2023; root:xnu-8796.141.3~6/RELEASE_X86_64 22.6.0
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: off
Legacy editor: off
Base theme: light
Community theme: ITS Theme v1.0.87
Snippets enabled: 10
Restricted mode: off
Plugins installed: 44
Plugins enabled: 43
1: Activity History v0.1.4
2: Advanced Mobile Toolbar v1.8.0
3: Tag Wrangler v0.5.11
4: Typewriter Scroll v0.2.2
5: Underline v1.2.1
6: Sort & Permute lines v0.7.0
7: Recent Files v1.3.7
8: Quiet Outline v0.3.15
9: QuickAdd v1.2.1
10: Obsidian Columns v1.5.0
11: Kanban v1.5.3
12: Highlightr v1.2.2
13: Graph Analysis v0.15.4
14: Footnote Shortcut v0.1.2
15: Focus Mode v1.11.4
16: Find orphaned files and broken links v1.9.0
17: File Explorer Note Count v1.2.1
18: Dialogue v1.0.2
19: Calendar v1.5.10
20: Checklist v2.2.12
21: Better footnote v1.0.1
22: Advanced Tables v0.19.1
23: Copy Block Link v1.0.4
24: Plugin Update Tracker v1.5.1
25: Periodic Notes v0.0.17
26: Commander v0.5.0
27: Image Toolkit v1.3.1
28: Sortable v0.3.1
29: Metadata Extractor v1.1.0
30: Style Settings v1.0.6
31: Dataview v0.5.56
32: Advanced URI v1.36.5
33: Editor Syntax Highlight v0.1.3
34: Imgur Plugin v2.2.1
35: Hider v1.3.1
36: Banners v1.3.3
37: Admonition v9.3.3
38: Omnivore v1.5.3
39: Excalidraw v1.9.12
40: Obsidian Leaflet v5.7.2
41: Double Click Tab v1.1.3
42: Omnisearch v1.15.2
43: Hover Editor v0.11.13

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Only new Property can change type. The old ones cannot be changed.

Have you tried to reproduce this with the community plugins turned off and/or in a sandbox vault? I can change property types for my existing properties without issues.

Yes, I turned off all Community Plugins and used the default theme. The Property Type cannot be changed.


Just did a little test in a new vault with a note with capo being defined as number.

Obligatory types.json output:

  "types": {
    "aliases": "multitext",
    "cssclasses": "multitext",
    "tags": "tags",
    "capo": "number"

I added 5 as the value.

Then clicking on the icon for the property type, I switched to text. That worked with the caveat that I now have a warning symbol at the end of the property stating, when hovering over it, Type mismatch, expected Text. Which makes sense to me, since Obsidian is seemingly not in the habit to mess with the frontmatter unless I do the action myself.

So it has:

capo: 5

and not

capo: "5"

in the note itself. If I do the reverse, text property with 5 set and convert to number, I get similar behaviour with the warning symbol, however, I would have expected the accompanying text to read differently. Right now it states Type mismatch, expected Text, but I would have expected it to read Type mismatch, expected Number instead.

In both cases, clicking the warning symbol prompted me to convert the data value assigned to the property and save the note.

I wonder if you have some data value for capo in a note somewhere that just completely blocks Obsidian to even try this? You might try a grep -R capo: on your vault location and see if any of those might be “weird”.

I think I know what’s happening. When I first tried out Property I named properties in capital (e.g. Instrument, Capo, …), then I change manually in the note to lower case (e.g. instrument, capo, …) It must somehow mess it up that I cannot change type. When I try changing types from other note, it works just fine.

1 Like

Thank you for pointing this out. I had exactly this problem.
To fix this, I deleted line with the old spelling of my property “Status” from the .obisdian/types.json.
Now I can finally change the Property type of my type “status” from “multitext” to “text” inside the obsidian GUI to make it work for Board View of Project Plugin. :grinning:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.