Cannot attach / see images containing a colon (:) in their file name

Steps to reproduce

I’m trying to add an image to a note. The file name contains a : (as it is a screenshot, containing a timestamp). Inserting this image fails: Dragging it into obsidian just makes nothing happen (disabled vim mode to be sure nothing was interfering).

This is extremely confusing. There is no feedback, no “invalid file name”, just … nothing happening. It’s by luck that I found out what the problem is.

Expected result

Insert an image.

Actual result

Nothing happens, not even an error message.


Obsidian version: v1.1.9
Installer version: v1.1.9
Operating system: #1 SMP PREEMPT_DYNAMIC Wed, 21 Dec 2022 22:27:55 +0000 6.1.1-arch1-1
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 1
Restricted mode: off
Plugins installed: 2
Plugins enabled: 0

1 Like

If you’re on Mac or IOS, colons in filenames may cause problems because they used to be the Mac folder separator (now it’s slash) and there’s compatibility stuff in place to handle it.

The “Operating system” field in your Environment info looks weird to me — I don’t know if that’s relevant.

Just encountered this same error today. I tried to drag in a pdf that a colon in the filename and nothing happened. It would be nice to at least get a toast that says “invalid filename” or similar.

I changed the colon in the name to a semicolon and then the drag-and-drop worked as expected.