Can’t unmap Alt-Up&Down Arrow hotkeys from swapping current paragraph up/down

Steps to reproduce

  1. Install Obsidian (version as of 2/16/22)
  2. Install and enable macOS Keyboard Navigation plugin
  3. Make sure NO hotkeys are assigned to Swap Paragraph Up and Swap Paragraph Down
  4. Place cursor somewhere in a long paragraph of text, and press Option-↑ and/or Option-↓

Expected result

Cursor should move to top and/or bottom of current paragraph.

Actual result

Current paragraph swaps up one line (on Option-↑) or down one line (on Option-↓).


  • Operating system: iPad Pro 2018, iPadOS 14.8.1, with bluetooth keyboard Logitech K811
  • Debug info:

(“Show debug info” is not showing up in the Command Palette—sorry!)

Additional information

I want Option-↑ and Option-↓ to navigate to, respectively, top/bottom of current paragraph (i.e. standard MacOS behavior).

The only way I’ve been able to prevent Option-↑ and Option-↓ from swapping the paragraph up & down is to assign Option-↑ and Option-↓ as hotkeys for any other commands; but then that cancels the move to top/bottom of paragraph function of the macOS Keyboard Navigation plugin.

Note that the select to top/bottom of paragraph function of the macOS Keyboard Navigation plugin works as expected.

Sorry, I can’t reproduce your problem and we don’t provide support for third party plugins.

Perhaps I included too much information. I don’t think the macOS Keyboard Navigation plugin is necessary. The problem remains without the plugin: I don’t assign any hotkeys for swap paragraph up/down, and yet the hotkey Option-↑ nevertheless causes the current paragraph to move up one line, and the hotkey Option-↓ causes the current paragraph to move down one line. The desired behavior in this case is for Option-↑ and Option-↓ to do nothing.

I think it’s possible this specific issue should be solved with Obsidian Mobile 1.1.0 (now available for insiders).

OK, I will try that. Thank you!

More info, in case it’s useful: I have just tried disabling all plugins, selecting the original default theme, and still having the same problem: Option-↑ and Option-↓ swap the paragraph up and down even though Option-↑ and Option-↓ are not defined as hotkeys for any commands. However, if I do define Option-↑ and Option-↓ to other commands—e.g. to Move caret up and Move caret down—then that’s what happens (i.e. the caret is moved up or down) and the pargraph is no longer swapped. This is the only way I’ve discovered of foiling the unwanted paragraph swapping, but it prevents me from using Option-↑ and Option-↓ for the purposes I want.

This would explain why I haven’t been able to reproduce the problem, hah. Sorry @MrPoetry! I’ve been using 1.1.0 as an internal build.

Just became an insider and installed 1.1.0 — problem solved! Thank you!

1 Like