Can’t access command palette

Things I have tried

I’m a new user using Obsidian primarily from iPhone/iPad.

Just now using the Configure mobile Quick Action command to pin command palette commands I have ended up with Toggle Italics as the only command available when I attempt to pull the command palette down from the top of the screen.

Normally the entire command palette would be displayed.

I don’t see how to change this.

What I’m trying to do

I am trying to get a few most useful commands to appear at the top of the comand palette list.

Need help with this. Kinda urgent. Obsidian pretty unusable, at least by this beginner, without access to command palette.

Screenshots would be helpful.

You fix it the same way you broke it: Settings > Mobile > Configure mobile Quick Action. Type in “Comm” and select the Command Palette command.

If you want to use the Quick Action for something else, you can add the Command Pallette to the Mobile Toolbar (at the bottom of Settings > Mobile you can add any command).

1 Like

I’m confused. When I first started using the app—again, primarily on IPhone or iPad—when I swiped from the top I got the command palette. Somewhere, somehow I got into pinning commands in the command palette. I thought it was in the command palette itself.

Subsequently I wanted to go back and add Toggle Italics to the group of pinned commands. It appears that I did it from the Configure Mobile Quick Action command not realizing that this was different from pinning commands in the command palette. Also not understanding what Configure Mobile Quick Action does.

The result was that Toggle Italics became my Mobile Quick Action. So now that I understand what Mobile Quick Action does I need to give some thought to what I want to dedicate it to, understanding that it can be quickly reconfigured ongoingly.

It appears that I pinned command palette commands under the command palette heading in settings. The problem now is that when I open the command palette—via the command palette in the App Ribbon—the commands I pinned do not appear at the top of the command list.

Another confusion: App Ribbon and Toolbar. (Is there such a thing as the App Ribbon? Where’d I get the idea that there is?)

I have a tweaked version of the Minimalist Theme. (I didn’t create it myself. I simply followed the recipe provided by a poster on Reddit. It promised to provide a Bear-like appearance. I was vaguely familiar with Bear.)

With this theme there’s a strip on the left edge of the left pane that has commands on it. Is that the Toolbar or the App Ribbon? If it’s the Toolbar it doesn’t look anything like what I’ve set up under settings > mobile > manage toolbar options.

That’s strange. Sorry, I don’t know why that would be. I have some pinned commands and they appear at the top of the list. They disappear if I start typing anything.

The Ribbon is the strip of icons at the left.

The Toolbar is the strip of icons that appears over the on-screen keyboard (with an external keyboard it appears near the bottom of the screen when you’ve tapped in the main note area).

Just double-checked. Still true.

Thanks. Perhaps I should make this another query, but is it possible to add commands to the ribbon?

The pinned commands are now appearing at the top of the list. At least on the desktop. We’ll have to see about the mobile apps.

1 Like

You can add things to the ribbon with the Commander plugin.

I have the same problem except my quick action somehow got set to toggle comment.

What I’d like to do, is not have a quick action set at all and simply be able to use the command pallet again. However, I don’t see an option to turn the quick action option off, nor an option to choose command palette from the list as you mentioned.

I wasn’t able to find a solution to fully remedy this, but I did find a workaround: The plug-in Quick Switcher ++ allows me to select “Open in commands mode” which opens the command palette. The available Obsidian plug-ins have come to my rescue many many times.

1 Like

It’s annoying that there’s no way to disable Quick Action, but you can set it to a command that doesn’t do anything noticeable, like Save current file.

To add the Command Palette to the Mobile Toolbar, go to Settings > Mobile and use the search box at the bottom, which lets you add any command (even ones that aren’t listed on that settings page).

1 Like

This is very helpful. Thank you

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.