Can someone help me with adding the metadata table to the top of documents?

Hey there. I’m having trouble adding the little metadata table. Typically, you would type — and another — and between them write in some headers, like “tags:” but it isn’t working for me - no table appears.

If anyone knows why that’s not occurring for me, please help out.

Merry Christmas and a happy New Year to all.

What I’m trying to do

Can you paste the Markdown you’re trying to use?

Put it in between triple backticks, so it shows up exactly as you are typing it. → ```

1 Like

Also, “showing up as a table”. Do you have a screenshot of someone else’s setup you’re trying to copy? I don’t think it shows up as a table by default. You are likely seeing someone using a community plugin?

1 Like

In addition to what rigmarole said, which would help us eliminate other problems, are you by any change on Mac, and have a text replacement for the triple dashes into that long dash?

If that could be the case:

  • Open “System settings”
  • Open the “Keyboard” dialog
  • Go to “Text Input”, and locate the triple dash entry, and remove that entry
1 Like



Not sure if the above images have come out correctly but that’s what I’m trying to mimic, to have that table at the top of my documents. (I don’t have a screenshot of their screen as it’s a YouTube video, sorry.)

I’m on a PC, not using any plugins or anything like that - it’s essentially a fresh install.

What I’m doing down below.



For more clarity, sorry. Doubled up on an above screenshot.

Is this set of instructions for a Mac-based version of Obsidian? Mine instructions aren’t showing what you’re providing, sorry.

The start of you note should look exactly like the block below:

---
Aliases: Unity, Unity Game Engine
---

You’re not supposed to have the triple backticks at the head of the file. That will produce a code block, like the one above here. It’s also important that there is nothing else before the first line of ---.

In addition you might need to verify that showing of the frontmatter is enabled, see Settings > Editor > Show frontmatter, and enable if disabled.

1 Like

Are you still running on version 0.14.6? It might be time to upgrade your Obsidian if that is the case.

Based on your last two responses, I’ve ticked Show frontmatter and it’s made a slight change, which is good progress.

I’m currently running version v1.1.9, so I’ll update that now.


The above is where I’m at now after toggling Show frontmatter.

Any idea why Keys is showing but not Tags?

You’re not supposed to use the hashtag when in the frontmatter, so try changing it to just: Tags: test1, test2, and you’ll see them come alive.

2 Likes

Thanks heaps for that.

Here’s the difference between mine and the video now. Any ideas?


Mine is the bottom, the video is the top.

The difference seems to just be visual now. And that is to expected since the video you’re watching are using Obsidian v0.14.6, whilst you’re using a newer version, did you say Obsidian v1.1.9?

Essentially, I think they’re the same now. Both defines some aliases, and some tags.

1 Like

Well, if it’s functionally identical, that’s fine enough for me.

Thank you @holroy and @rigmarole for helping out - especially over the holidays. Couldn’t have done it without either of you.

Merry Christmas and a happy New Year.

2 Likes

Actually, one more thing. It seems in those screenshots (the video) that the document isn’t using a title for the document at the top in big, bold text. Is there a setting for this? My documents always need a heading at the top.

Check if not Settings > Appearance > Show inline title is the one you’re looking for. Enable or disable as you like.

1 Like

Wow. Legend. That did the trick. Thank you so much.