Can not open devtool by `ctrl+shift+i`

On windows 10, obsidian 1.03

I have confirmed ctrl+shift+i is working on chrome, so there is no global hotkey conflict.
I am trying to add some custom css, so devtool is necessary. How to solve this problem ?

I’m not sure why, but I sometimes have problems opening the devtools myself. What has solved it for me is to reduce the number of open tabs and panes.

So try reducing open files, maybe as far down as to a single file open, before opening the devtools. After it’s opened, you can reopen other files again.

If that still doesn’t help, even after restarting Obsidian, you might consider disabling plugins/themes, and/or going to the Sandbox vault. But I don’t think you need to take that route.

You or a plugin might have assigned something else to Ctrl+Shift+I ?

You can use this code to list all your custom assigned keys:

const getNestedObject = (nestedObj, pathArr) => {
    return pathArr.reduce((obj, key) =>
        (obj && obj[key] !== 'undefined') ? obj[key] : undefined, nestedObj);

function getHotkey(arr) {
    return arr.hotkeys ? [[getNestedObject(arr.hotkeys, [0, 'modifiers'])],
    [getNestedObject(arr.hotkeys, [0, 'key'])]].flat(2).join('+').replace('Mod', 'Ctrl') : '–';

let cmds = dv.array(Object.entries(app.commands.commands))
    .where(v => getHotkey(v[1]) != '–')
    .sort(v => v[1].id, 'asc')
    .sort(v => getHotkey(v[1]), 'asc');

dv.paragraph(cmds.length + " commands with assigned hotkeys.<br><br>");

dv.table(["Command ID", "Name in current locale", "Hotkeys"], => [

I don’t know why, but it become normal now

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.