Can no longer login a Google account inside iframe

I can no longer login to my Google Account from Obsidian – which I did before successfully.

Steps to reproduce

in a fresh not insert

<iframe src="" height="1024px" width:="100%"/>

and put in your e-mail address. After hitting next I am provided with the message

400. That’s an error.
The server cannot process the request because it is malformed. It should not be retried. That’s all we know.

Expected result

Actual result

I expect Obsidian to login and stay logged in like any other browser


  • Operating system: MacOS 12.5.1 (Apple Silicon)
  • Debug info: This worked before

Additional information

1 Like

these are not the debug info asked in the template.

Sorry – You can find the debug information below.
I also tested that this issues is also present in the Sandbox Vault (I was not aware of that until now).

Debug Info:

	Obsidian version: v0.15.9
	Installer version: v0.15.8
	Operating system: Darwin Kernel Version 21.6.0: Wed Aug 10 14:28:23 PDT 2022; root:xnu-8020.141.5~2/RELEASE_ARM64_T6000 21.6.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: Big Sur Aesthetic
	Snippets enabled: 5
	Restricted mode: off
	Plugins installed: 28
	Plugins enabled: 23
		1: Advanced Tables v0.17.3
		2: Calendar v1.5.10
		3: Copy button for code blocks (fixed version manifest) v0.2.1
		4: CSV Editor v0.0.1
		5: File path to URI v1.3.0
		6: Find unlinked files and unresolved links v1.5.2
		7: Dataview v0.5.38
		8: Templater v1.12.0
		9: Day Planner v0.5.8
		10: Imdone Obsidian Plugin v1.0.0
		11: Editor Syntax Highlight v0.1.3
		12: Mind Map v1.1.0
		13: Kanban v1.2.40
		14: Admonition v9.0.3
		15: Advanced Cursors v0.5.1
		16: Dynamic Table of Contents v0.0.27
		17: Show Current File Path v0.5.2
		18: Smart Random Note v0.2.1
		19: Minimal Theme Settings v5.3.0
		20: Tag Wrangler v0.5.2
		21: Recent Files v1.3.2
		22: Copy Block Link v1.0.4
		23: Excalidraw v1.7.22

	Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

I also have this exact same issue when I try to use iFrame with google sheets.

download and reinstall obsidian.

Does it work in the sandbox vault?
Do you get errors in console (Ctrl-Shift/Opt-I)?

A reinstall did not solve the issue on my side.

I retried the login using youtube in an iframe and checked the console for the same.
There I found two errors:
The first just preventing the auto-focus on the input box, the second is the 400 on a POST request (find them below).

Maybe Obsidian / the iframe encodes something wrong on this requests, since 400 means Bad Request?

The Sandbox mode also fails.

In order to check the login on other platforms I tried amazon – There I get the an error saying Please Enable Cookies to Continue. Did Obsidian or Electron change something in this department?

Blocked autofocusing on a <input> element in a cross-origin subframe.

POST<<token>>&service=youtube 400

Can you reproduce the issue?

Post a screen recording of this happening in the sandbox vault and make sure to show the console window for errors.

you can find the screen recordings in the google drive folder below:

I did google and seemingly there are security issues with iframes.

You may want to look :

Google Issue Tracker

Error 400


It may not be a bug after all.

@looney.apache: It is still a fact that it worked before – Would be nice to make it work again :smiling_face: .
Also the autofocus should be irrelevant – It looks more like an issue on the request side, since it shows up after the submit.

Also amazon inside an iframe complains about disabled cookies. To be honest I am not sure if amazon worked before within an iframe in Obsidian, but I think cookies (in electron) could be worth a brief investigation here.

is there an artefact registry providing old builds of obsidian so I could test this issue on an older version of obsidian?

To the best of my understanding, electron apps use the chromium browser engine. Apparently, there have been some modifications in the past couple of months that may have affected how YouTube and Amazon login function.

I’m not sure, but might we install an earlier version of Obsidian to test whether the problem still exists?

Is there any update regarding Google account login via iframes? I also get error 400, as described above…


downland and reinstall obsidian. is this still happening?

I’m still having this problem on a newly downloaded Obsidian. Same issue as OP, on the same platform.

are you getting?

400. That’s an error.
The server cannot process the request because it is malformed. It should not be retried. That’s all we know.

or something else.

Yes, I am getting that error.

ok, so. Some websites don’t support logging in via iframe (like youtube).
To login, you either have to use Canvas or the plugin “custom frames”. has some specific problems and we can’t do anything about it.

1 Like

That Custom Frames plugin works like a charm. Thank you for the pointer!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.